The port forwarding thread

This is probably the most difficult part of getting started with on line gaming so
I figured it deserved it’s own thread. Even though I PERSONALLY wont have all
the answers, there are some really knowledgeable people in the community that might be willing to lend a hand so come up in here with your questions.

OK the first thing you have to do is find out which type/model of router you have.
This I can’t help you with so you are on your own but I’m guessing most of them have something ON them so look at it first. I think there is also a way to find out through Windows like through control panel but I cant remember so if anyone knows then feel free to post it up. Just trying to be as helpfull as I can.

OK next on the list is getting into your router. I personally use Windows XP so I’ll
start by posting the way I get into mine.

Hit the Windows key + R and you will get a little screen. Type in cmd and hit enter. You’ll get a black screen. Type in ipconfig and hit enter. You want the number that says gateway or something like that.

If you type in ipconfig/all you will get a lot more info. that might be usefull but some one else will have to fill you in on that.

Once you have the gateway number than open up your Internet Explorer and in the address bar type in that number and you should be inside your router.
If that didn’t work than here is another suggestion. Instead of the gateway number, type in home and then cross your fingers.

Now comes a potential road block. If your shit is behind a password than your shit outta luck if you don’t know it. I do have one thing for you to try though.
Look at your router and look for some kind of serial number. Give that number a shot and hope for the best.

Next you want to go here


and fuck it…even here

The more you understand this shit the higher your chances of success are.

Look through those and see if you can find your router or the info you need.
If all that fails ( don’t be lazy and NOT look through them ) and if you still can’t open them than come here and ask away. Of course screen shots always help but don’t make them all huge to where it fucks up the thread.

Well thats all I got so if any one else has any thing to add, be my guest.

Good call, djfrijoles. The port-forwarding issue has been getting more and more attention since the rise of the awesome P2P client.

You’re going to need a little bit of technical knowledge to get things working, but if you’re willing to do a little homework and tinker with things, you have a good shot at success. If you have a problem, you have the best chance of getting help in here if you give a good description of the issue and show that you’re making an honest attempt to meet people halfway as far as effort goes. :tup:

My port forwarding is not working (for real =()

I have a D-Link DSL 302g and I used to use it’s bridge mode to connect directly to ISP from my pc so I didnt need port forwarding. Some dude told me that JetSpeed 520 firmware has UPnP and works on Viking and I upgraded and now I can’t use bridge mode. So I port forwarded and it was working and then after I added a few more forwards for utorrent and a few other programs…it stopped working. I removed the recently added ones and it doesn’t work even if I do everything from scratch.

Someone help a newb out! =(

You are the last person I ever expected to be in this thread asking for help:rofl:

Well I don’t have much cept this guide that I found for your model.
Might not be much use to you since you already know how to port forward but
hopefully the community will show there appreciation for your work and chip in and look for the answer. Any ways here it is

Ok, i’m having a problem. My DSL modem isnt showing up on that site. I have a ActionTec GT724WG. I need whatever help I can get pleeeeeaaaaasssse.

Ok I got a question for your question first.

Are you able to accsess your routers config. at all ?
If so how much of port forwarding do you understand. If you are able to access the config. than shoot us a screen shot and we’ll see what we can do.

Did you check to make sure your firewalls are off? …just kidding… haha :wgrin:

That is weird, though. You had forwarded ports working before, so clearly you knew what you were doing there. When you say you later added a few more ports for utorrent and stuff, how much later was it? Fifteen minutes later or like a couple weeks later? If it was a lot later, it can’t possibly be because of something whack like your ISP suddenly disallowing the 27886 port at around the same time you went to add the new ones, is it?

I don’t suppose reverting to old firmware is possible/desired. I dunno, I’m looking for ideas here but mostly coming up empty. Google is not helping much either. :sad:

If you’re plugged straight into a modem, I thought usually that situation doesn’t require port forwarding at all. Are you behind a router? Is that what you meant?

Well I don’t know exactly what it is. Its our main modem for DSL between my computer and my dads computer but it is giving me the problems I had with our old router when we had cable. None of my games are showing up in the waiting games list and my ping is higher then it was but then again the latter could be from the fact that DSL sucks.

One of the easier solutions for port forwarding problems is get yourself a software firewall and put your PC on the DMZ.

I’m not trying to sound retarded, but do you know if you could find out (what it is)? It would be really helpful if we knew whether you were behind a router or not. Or are you saying it’s some weird “modem and router all in one” thing? Does your dad know? Commonly, people have a modem and a router setup.

Not trying to be disagreeable, but personally, I’ve heard too many horror stories about the DMZ to even consider using it to try to fix the issue, especially when we haven’t exhausted all our options. I’d be too scared to mess something up with my computer or the others on the network, even if I thought I knew exactly what I was doing. But I am no tech guru.

A friend with the same router sent me a copy of the old firmware. Bridge mode is working now =) Couldn’t find the firmware on google anywhere…not even on the router’s company site. Thanks for all the help.

Sounds to me that it could be a DSL modem + NAT combo. If it has NAT features, then you should first enable it into bridge mode… I think. I’ll double check for you about NAT modems.

The DMZ is no different than connecting to the internet straight through a modem - ie:no router.

Obviously there is security issues with that as your PC is basically naked on the web, which is why you need a software firewall.

The advantage of a software firewall in this scenario is that they are generally application specific in terms of allowing outgoing/incoming traffic. A router blocks ports regardless of the applications trying to use it where a software firewall will prompt you when a application needs net access and you can approve or deny. That alleviates the need for port forwards because the application itself will/should have full access.

If ports are forwarded under a certain administrator account on a PC, do those settings apply to the other administrator accounts?

It should. Port forwarding is an aspect of the hardware end of the router, not the operating system on the PC.

I seem to be having a bit of trouble with this. i’ve forwarded the correct port for p2p, but for some reason whenever i hit the “whatismyip” button on the host screen it shows the port as being 60205, or really just a random port starting with 60. i’ve changed it on my router to forward the port and also on my firewall, as well as force the port on the client. still get the random 60 number.

As a matter of fact, i never really did anything when i first tried to host. it just worked. i didn’t forward the port until a couple days ago. it says it’s hosting on the 27886 port but whatismyip button is showing up as xx.xx.xx.xx:60205.

any help would be appreciated.

I think that when you conect to some one else instead of hosting yourself, the port you guys played on gets recorded and shows as the hosting port for your next session.
Not completely sure about this though.

Are you able to host though ?

You can change the port you want to host on in the options tab ( asuming you are using nFBA p2p client )

If you are still having trouble then hit me on AIM and we’ll see if we can’t get you going.

oh yeah, forgot to say i was using nfba and all that jazz.

yeah i can host just fine, i would just like to have the 27886 port being used, so ppl don’t have enter it in every time, and wonder what port i am going to use, cuz it does change every time i host.

it’s like a dynamic port number, even though in the settings I’ve made it static at 27886. It is an oddity.

also, the reason i want to change it is because i get weird freezing issues with some of the ppl i play. the game locks up and the sound keep repeating over and over. i’ve been trying some things on my comp to see if i can get rid of it, and this port is just an idea.

i also have an idea that it keeps happening because i’m using vista and everyone else that i’m playing is using xp, but that is kind of far fetched.

It’s not to far fetched as you might think actually.
From what I’ve read it seems that Vista doesn’t get along with emu’s.
As far as the freezing issue you mentioned, make sure the people you are playing
are not using the beta version of the p2p client ( which is the most recent vers. )
Feb. 11 is what most of us are packing latley ( I think )

You also didn’t mention if you tried checking what it says in the options tab in the net play screen.

Help please!

Allright, on p2p kaillera for 3S, I’ve forwarded my ports, disabled my AVG program, and I still can’t host at all.

I have 2 ports forwarded for kaillera and 1 for Starcraft. I just don’t understand what else I can do. Did I forget to do something? Or maybe I did something wrong? I’d appreciate the help. Thx.