TE Fightstick Button Issues?

medium kick feels sticky and just wrong.

but i’ ll have my sanwa hardware soon!

I’ve had this same issue. Should I have Madcatz service my stick before I replace the square gate with my octagonal? When my RT goes out, I just unplug it and plug it in, it’s only happened twice, I don’t know the symptoms. I do know that sometimes it feels like my buttons don’t respond but when I play shooters the stick works just fine.

I spoke with someone at Madcatz UK Technical Support, now the technician believes it could be a faulty button. I mentioned whether it could be a dodgy PCB but he said if that was the case then the button would not function at all. So he sent me new button which i recieved today. Will fit it in the next couple of days and let you guys know if it sorts out the problem with my RT button. If not, then the stick is being sent back to Madcatz for further inspection…

tested your stick for about two hours and no problems. i’m going to test tomorrow to see if the problem is really your xbox360. im using a really old xbox360, the one without hdmi

^WoW that’s weird. I also have the old and the new xbox 360 version, and the roundhouse button still goes out on me after about 1 or so of play?

I have similar problem as well my RT button just stops for no reason.

I opened my TE stick to check what’s wrong with it. I just jiggled the quick disconnect a bit and it started to work again.

It hasn’t given me any problems since then, but I’m still a little worried.


I have 2 TE’s for XB360

Stick 1) Right when I got it home I swapped out all the buttons and put on GXE’s Alex image with ArtHogs Acrylic overlay. In doing this I never tested if everything was working fine, but I did make sure all the QD’s were snug. This stick has had 0 problems.

Stick 2) I opened it up to clean it out, and re-adjust the Cable (Previous owner pulled it in a bit so the Bulb stayed inside the door) Then I tested it on windows and the RT wasn’t working. I looked inside and the QD’s for that button on the terminal strip were VERY loose, pushed them down snug and it’s been working great ever since.

My PS3 TE has this problem as well, the roundhouse button (R2) doesn’t drop out completely but after playing for a while it still works but with a delay of about a second.

i left the stick on turbo for RT today for about 3-4 hours, no issues. im going to unscrew the panel and see whats up

I opened up the stick, disconnected the RT button, reconnected it and has worked spot on since, no problems what so ever.

yeah i had this same exact problem too. did you remove the LT LB buttons? well i removed mine and when i moved the stick around, i assume the wires for the L buttons crossed and shorted out some of the fuctionality of the pcb, the RT would be dead and the turbo functionality would be dead also. Just remove the wires from the terminal strip altogether and you should be fine.

Turning on TURBO to quick fix?

Ok, I have a 360 TE dual modded with a MC Cthulhu. My main system is PS3 and had been playing with NO problems whatsoever.

I cracked open my 360 copy of SF4 and started to play, unlocking characters etc. Lo and behold I can confirm the same exact types of issues with the buttons not responding – specifically the RT and LT buttons (which are my mk + hk buttons respectively).

It has happened now three times in 8.5 hours of play. The first two times, I remedied the issue by unplugging/replugging the USB cord and break-away cable.

This latest time however, I paused the game and tried to turn on TURBO functionality for those non-responding buttons. That did seem to work, as the corresponding LEDs came on and the buttons started working again.

Can someone else please confirm this trick/fix the next time it happens to you?

I had the same RT issue as well with my 360 TE. I’ve only had 2 real sessions with the stick, and it’s only happened once.

I called Madcatz tech support, and they insisted that the button was probably dirty. I explained that the stick was just purchased yesterday, and that the problem went away as soon as I replugged the stick. They weren’t really sure, but said to call back if I continue to have problems with it.

I hope they can resolve this issue for us. Maybe someone should shoot them an email with a link to this thread, eh?

i have a xbox 360 te, which i have just swapped art out and plexiglass.

but after practicing with it in training mode, i realized 1 out of 20 times when i do focus attack and i hold the buttons down it still releases, usually almost immediately and sometimes half way through the focus attack.

what i usually see on the input display is


so i went to test throws and 1 out of 10 times the input display will show


and when this input is displayed i can see ryu jerk very quickly then grab. (almost looks like a kara throw)

any ideas? i havent swapped buttons around and tested them which i will later, but any other ideas?

Out of 3 360 TE sticks, mine is fine; another has the ‘RT stops working’ problem, and another one ALL buttons and stick directions stop working. Unplug + replug fixes in both cases.

Both of these were from the 2nd batch sent over to NZ.

After talking with some people in srktt, the conclusion is that it HAS to be a 360 PCB issue, nothing else is consistent with the symptoms and remedies.

Easy fix, take the unuse LB wire and connect it to the rt button. Problem fixed.

md72582: good idea, and probably what I’ll do if I don’t return it to gamestop.

I still think they need to be recalled, or send us new PCBs…or something. This is kind of ridiculous.

Btw, I encourage more people to email or call Madcatz and tell them about these issues. It would definitely help out.

I just got my TE the other day and I was playing and I was wondering if anyone ever noticed any issues with EX moves or FA moves triggering just by hitting one button. Now I know the sticks are Japanese parts which are traditionally MUCH more sensitive, but it happened a few times to me last night and I was wondering if I’m just being too rough on the inputs and accidentally triggering/hitting additional buttons or if there might be some sort of wiring/sensitivity issue going on. Just curious if this has happened to anyone else.

I had a similar incident with my modded SE Fightstick. I have Sanwa buttons and stick in it. In the middle of a random match, my RT and LT buttons stopped working. I started troubleshooting the issue by disconnecting and connecting the wires back. Then I disassembled the actual buttons to see if there might have been debris inside the button. Everything looked fine. I tried connecting different wires to the buttons that didn’t work to begin with, and they worked using different wires. That narrowed it down to the wiring, rather than the buttons themselves. So now I was looking at the pin connectors from the button wires, to the mainboard, and they all seemed okay. Nothing out of the ordinary. I let the game and the Fightstick sick for a couple of hours and now everything works. I can only attribute this to an electric short. I wanted to post this so someone who might have a similar problem in the future can try these steps and tips to figure it out.

Is anyone else still having these type of issues that are “resolved” by replugging in or has anyone found a more concrete resolution?