Post here if you get the "Your post needs to be verified/approved" message

You should be alright now.

@Valaris got this on the adon forum. Thought I just closed the tab and rewrote it once more. If you could just send either one of them through I’d appreciate it

Fixed. Also, please remove images from your signature.

Checking in for this issue. I got it in the ggate thread. Apologies for muti-submits!

You should be fine now.

i got one from trying to post a youtube link


@Valaris I posted in Tech Talk a few days ago and got that message. Thanks in advance.

@bmoc‌ You should be good now!

hey @Valaris

@d3v sent me your way. i didn’t realize one of my posts on tech talk needed to get approved before appearing - never dealt with that before. thought something was up with my comp. anyways if you see like 7 posts of the same thing just use the last post and ignore or delete the rest. my bad. its in the recent “Think about building/buying a gaming pc?” thread.

@jonyfraze You should be good to go. Apologies for the delay. Unfortunately you will need to resubmit your post.

I cannot post a single thing in this topic:

I tried to post something to classifieds and I got this message. Can you please take a look? Thanks!

You should be good now.

I got the message in 2 posts in tech talk. Please help

Also, what causes this? Thanks.

Was the board upgraded? Moderator approval queue has got toooons of posts flagged.

Note to mods:
In order to clear anybody from the queue, you’ll want to open up their profile page in another browser window/tab so you can then delete all the double/triple/quadruple posts that fixing somebody (by marking them as Not Spam) will cause. I only ever do one fix at a time because otherwise things get crazy.

edit: Hm. Looks like some mod is clearing flags without clearing the bonus posts. If you somehow see double/triple/quadruple posts etc after you’re fixed, a mod should be able to fix that for you. :\


I have the same problem. I would gladly accept a fix.

Yep, I tried making a thread and got the same message.


I have same problem too.

I have the same problem, I can’t post anything without moderator comment approval.