Weird TE stick (PS3) problem

Ok guys, i have a te for ps3 duel modded for ps2 and i went to a tournament and now my te doesn’t work on ps3 at all but it works on ps2 just fine.

When i plug it in to the ps2 and i play guilty gear the turbo light comes on every button i push (im use to seeing that only for ps2) now the turbo flashes for ps3 which never happens and i cant press or move anything but when i go back to the ps2 it works just fine , all inputs and commands work. has anyone had this problem or is there any solution for this problem?

Try plug it into a computer and see if the buttons registers first. This might help you narrow down the problem.

i just did that and there is no response, when i put it back in the ps3 the turbo light comes on once i press any button…then went to the ps2 it works just fine

What dual mod set up do you have

umm its an imp board and a ps1 controller board
to my ps3 TE

What is the Imp for in your setup?

Before Tournament, the Dual Mod work on PlayStation 3?
How long it been working for?

honestly idk my friend modded it for me, i can take pic’s if that helps and yes its been working until i went to the tournament and came home.!/photo.php?fbid=167402006623300&set=a.158025697560931.29011.100000605056365

I don’t know what the Imp in your setup is for either.
It is not needed.

Post some pictures.
Maybe there is something loose for PlayStation 3.

te.jpg picture by mgvfinest - Photobucket here’s my stick and

I don’t see an imp board inside there, just a psx pad (which is a good thing since an imp board has no business in this mod).

Try setting the stick selection switch to DP (d-pad). This won’t solve your entire problem, but might help with char/menu movement.

make sure the ribbon cables going from the ps3 pcb to the wire harness terminal doesn’t have a ripped wire.

How are the wires for the psx button signals wired to the te?

Like Gummowned said, I do not see Imp.
Do you really have it?
Is it hidden?

Yes, for sure the switch is on LS right now.
Should be DP.

I just got to think more for why the Buttons to not work for PlayStation 3.
I don’t want to think right now.

oh wow… ok umm this is what happend, i asked to get my stick modded and he said buy an imp board and a ps controller, for the dp solution, its still the same result. I was looking for any ripped wiring and i didnt find any, then again there are so much wires.

looks like the button signals on the ps1 were connected to the button terminal strip. I’m just guessing here but was this dual modded after the tourney?

no, it was duel modded along time ago like 6months or more.

So did the ps3 side work at all for any period after the mod?

yeah it worked until i went to the tourny.

hmm, lets say my ps3 board is loose, what do i screw in.