Weird PS360+ Start bug

(I am not intelligent. Lemme just preface with that.)
Okay, so I just got in the PS360+ for a friends stick that I’m making.
I get everything all nice and set up, no biggie.
I get 1.31 installed on it.
So I fire up AE to test it. I go to practice mode, grab Abel and yeah.
So I’m all okay lets do combos.
The second I plink HP, it pauses the game.
In fact, every time I push two adjacent buttons, it pauses the game, except for Vertically adjacent buttons, for throw, focus, and taunt. Those work.
I tried unplugging Start from the thing, and i find out that it cant even register simultaneous inputs except 3P and 3K.
So I do Ultra1, but the second he lands, then I find that none of the buttons are working.
I just have no idea what is going on.
Then I tried installing 1.3

Take clear pictures of your wiring.
It’s difficult, if not impossible, to troubleshoot with just a description of the issue symptoms.

Okay, well.
i fixed it and it was something ABSOLUTELY ridiculous and nonsensical.
the stick case used to be one of those shitey XArcade two player things, and i cut it in half to make two sticks, and i wanted to keep the p1 start button cuz it looked cool, but apparently those were the problem somehow? I replaced them with old sanwas and poof it works.
How do I delete threads.

Okay repeat again in English please.

There should be no logical way replacing a button fixed your issue. There is more that isn’t said.

Okay, I’m sorry.
No, I believe the buttons I was originally using were faulty anyways.
Normally with the PS360+ you have to hold start while plugging in to go into bootloader mode, right?
That didn’t happen for me. I just plugged it in and it immediately went into bootloader mode. That quickly changed after I swapped the start/select/home buttons with Sanwas. The other buttons must’ve been effed up.
That and at first, the 6 buttons and start/select/home buttons had separate daisy chain grounds. After I put in the replacement Sanwas, I put them all on the same ground wire.
It’s all put together and works now anyways so. I don’t know. One of those fixed it.
Sorry about the atrocious grammar in my last posts. I was tired and frustrated.

Grounding issue with the buttons.

My money is on that the original Happ-wannabe Start button was connected with the ground/signal wire on NC (normally closed) rather than NO (normally open).

Switching to the Sanwa button eliminated that because there’s no option for NC anyways.