USF4 PC Version FPS Drops

I have a technical problem with USF4. It started on a GFWL version of Super Street Fighter 4 Arcade Edition almost two years ago. Frame rate starts to degrade over time (in a span of 10-15 minutes), it decreases from solid 60 FPS to 59, then goes below 50, making the game unplayable.
System specifications:
OS: Windows 7 Ultimate x64
CPU: AMD Phenom II X3 720 (2.8 GHz)
Video Card: AMD Radeon HD 6770
I found a lot of people with similar problems around the web, and here is a list of things I have tried to fix the game for me.

  1. I updated my video drivers various times to the latest version.
  2. Enabled / disabled V-Sync both in-game and in AMD Catalyst Control Centre. I have tried every possible combination of these settings. Catalyst V-Sync also adds screen tearing.
  3. Tested the game on all three “Framerate” options. Fixed is still the most viable one.
  4. Turned “RenderingThread” parameter on and off in the “config.ini” file.
  5. Disabled every graphics option to its lowest setting possible.
  6. Tried launching the game in lower resolutions and in windowed mode.

Every single one of this solutions doesn’t change any of conditions written above: the game runs at 60 frames for 10 minutes, then performance suddenly drops, so it’s not about my PC not being able to handle the game at 60 frames-per-second, it’s almost like it grows weary after a few minutes, and that is what’s causing the whole ordeal. Alt-tabbing helps for a few seconds, but the best solution is to quit the game and run it again.
From my observation, this FPS degradation started sometime after July of 2013. Both versions of this game (original SF4 and SSF4AE) were working perfectly on my PC before this period of time. The only change in my hardware was adding 4 additional gigabytes of RAM. Not a single game has changed negatively except for USF4.
Did I miss something? Please, help me fix this problem.

Hmmm. That computer should certainly run SF4 perfectly. That’s better than my computer by a fair bit and I get ~130FPS in benchmarks usually. Wish I knew the answer. Do you have anything running in the background that could be causing it? Like an antivirus scanning or something?

There are no performance-heavy programs running in the background, only Steam, AMD Catalyst and AVG Antivirus, which can’t be a culprit for such persistent FPS drops.
Also, I recently tried installing vanilla SF4. It’s also affected by this performance issue. So it’s either video drivers or there is something wrong with my hardware. I guess SF4 isn’t “meant to be played” on my AMD video card, which is even more baffling considering that my old PC with a single-core CPU and Radeon X1950 GT ran the game on mid settings 60 FPS without anything quite like this.

Try newer or older drivers?

I think you might have a hardware problem sir. Because it seems to be degrading over time it sounds like a heat problem. Either your CPU or your graphics card are overheating. I have almost the same setup as you and have no issues.
My PC:
Win 7 Ultimate 64bit
AMD PhenomII X4 970 black
8GB DDR3 1600
Radeon HD 5870 1GB

Ever since Ultra came out a friend of mine has been experiencing fps drops as well.
His rig:
16 gb Ram
256 SSD
gtx 970

Long story short…Capcom plis

It might be the case. I’ll try running HWMonitor in the background. Though, as I stated in the original post, USF4 is the only game affected by this.

I have been fiddling around with Graphics options and discovered that turning off Motion Blur and switching Soft Shadows from Extreme to High somewhat helps, and the game looks almost the same. Hope this helps.

you can try to force “maximum peformance” instead of “adaptive” in your graphics card panel (creating a profile for the game) but don’t know how’s called on radeon

maybe the game is not too demanding for your card overall and drivers revert to low power consumption mode

i have a nvidia and resolved this way with some games that had huge frame drops for no apparent reason

So I kind of abandoned this thread since the game became somewhat playable, I don’t even know how. And then I had to reinstall my OS due to HDD failure. Now USF4 is unplayable for me yet again. Tried forcing V-sync via D3DOverrider - it does nothing. I did some more research and found out that AMD driver support is horrible: latest version of Catalyst (14.12) adds seizure-inducing flickering to Skyrim, a three-year-old game that ran perfectly, just as SF4. This whole issue has got to be caused by drivers.

I’m afraid there is no such option in Catalyst.
It seems like the only solution is to buy a new video card, and unfortunately enough economy in my country has hit rock bottom recently, and buying PC hardware is a total waste of money. So no Street Fighter for me in the near future.
Remember kids, if you like to play old games as well as new, AMD Radeon is a bad choice. Drivers that retroactively break five-year-old games - that’s not how support should work.
Thanks for everyone who left a comment and tried to help.

I have the same problem with my Nvidia card(s).

I think it’s a driver problem too. Back in 2010, I could run it just fine and dandy with my GTX260. I think that by Ultra, the performance went out of whack.

I bought a second-hand GTX460, and the performance is perhaps worse than the 260.

I can’t believe this.