TvC stick with PC not working

Hey there, I’ve been lurking the forums quite a bit lately and after becoming more interested in this game I decided to jump in and buy a Tatsunoko vs Capcom stick and the Mayflash Wii to USB converter.

For some reason, the stick does not work on my PC for SSF4AE. However, it works perfectly on my PS3, on SSF4 (not AE). I’m not sure if its a driver error, but I tried every instance of either having them or not and it seems to just not work. The two devices are indeed connected, I can see both of them through the device manger and even change the settings through the properties, but ingame no stick movement or button presses are doing anything. I did indeed try different USB ports, and the problem persists (not sure if that would’ve been a solution either way).

So I’m hoping any of you geniuses here at Tech Talk know what’s going on. I would really appreciate some help, and I sort of feel bad for making this my first post here on SRK, but I’ll try to stick around :smiley:

Switch from DP to LS?

I’ve tried that, no luck

This thread may help you in your search:

Wrong stick.

At this point I’ve tried even more things regarding drivers … such as only using the Mayflash ones while not using Windows drivers, or using Windows drivers and not Mayflash, etc… and still nothing works. Very disappointing, I can’t say I’m quite sure what to look at next. It’s just puzzling that in the properties for the devices I can see every movement and button work, but it doesn’t work outside of that - maybe it has something to do with key mapping? But from what I could find there was no indication that the possibility of changing keys to match keyboard buttons (like the default 1234-QWER for keyboard PC players) is possible, which would probably fix it.

Use Joy2key. AE on PC still has controller issues with non official stuff.

I use my TVC stick with SSF4AE with no problems EXCEPT ONE. For some reason until I get to the main menu it wont recognize the “start” button so I have to skip through the intros and such using my keyboard. After that though it is no problem. Start works find in-game just not for skipping menus or “press start” at main menu.

Try this:

First make sure you are running the official mayflash drivers (and that they are up to date.)

Then go to your devices in windows and make sure to calibrate it (should be in “devices and printers” or something like that. Right click on the mayflash wii classic controller and select game controller settings then check the properties for it to make sure it is calibrated properly) Make sure to go to “button remapping” and set the “two trigger button” to “use as button” not “use as slider” otherwise the L and R buttons wont work right.

After doing all that, open up street fighter 4, then using your keyboard go to options and select button config, then press the right or left arrow keys until you see “May Flash Wii Classic Controller” show up at the top part of the menu. After that reconfigure your keys and you should be good to go. (B A R should be LK MK HK Y X L should be LP MP HP)

Make sure you have the switch set to either LS (Left Stick) or DP (Directional Pad) otherwise it wont recognize your joystick inputs.

Yeah, the problem is that ae does not recognize the controller. I used tocaedit’s xbox controller emulator. Setting up is easy and all the menus work in game.

Thank you so much! This worked perfectly :smiley: