Tough time with

When I suggssted new features for Xbox, they suggested I post my ideas on The last 2 of the 3 times I tried, it looks like the Xbox abandoned their company generator. Oine successdul thig I sgested that came true was due to my low bandwidth issue.

If I wanted to do something with my internet, and the Xbox one was at its maximum 1.5 Mb/s in, the highest possible that is gaming compatible based on my physcial adress, (I douby anyone can limbo under that one). It was an annoying if I had 12 games un queue, and then in order to turn off the internet to give something else mrfe juice, I suggested a Pause All and Resume all button.

Before, i shut oe game down, then it takes some time to register, then the next, etc. each taking about 10-20 seconds each game. Now, it’s one step pause, one step resume.

Now it looks like xbox.uservoice.,com and its successor arer both at a defualt out-of-business sign. 2 of the 3 Xbox agents suggested it, including the security department, one of them gave me the corporate security number, thinking I might have have banned from, and when I tried gopro,, I was able to log in and post, so it’s a local to Xbox issue. I called security, tey checked the site, and they saw proveribal out of business sign,

One agent recommender I tried to sign up. FIrst I tried chrome on t old 10.9 computer. No sign up window showed up. Tbehn I tried Chrome on my currnt OS Mac, same thing. I guess it’s not compatible with Chrome. Then tried Safaria and I got to the registration form. IOt said wait for the emai. Ive been waiting for 2 hours. i checked my earthlink webmail site, and found nothing from them, but had a recent email. I checked trash. I tried irefox on the new computer, but it even load the website.

For a mac, any other suggestions for a browser? Also I don’t know if I should send again or not. it restarts it, but puts you in the back of the line.

Anyone know why 2 hours to get a email on call and nothing happens?