The Beginners guide to: 2DF | GGPO | Kaillera | MAME | ZSNES | Port Forwarding

:wonder: Here you’ll find a brief summary and links to various game emulators and a port forwarding guide. Just click on the names below for more info.

[list]2DF []GGPO []Kaillera []MAME[]ZSNES [*]Port Forwarding[/list]


2DFighters site can be found [here].

From damdai’s official [2DFighter thread]:

From the 2DFighter site:

GGPO’s site can be found [here].

GGPO IRC can be found here: #ggpo on

From the GGPO site:


Original thread [here]

From 0746:

:tup: Thanks to 0746 for the great guide… dood!

Multiple Arcade Emulator

Original thread [here]

From fatherbrain:

:tup: Thanks to fatherbrain for the great guide… dood!


Original thread [here]:

From fatherbrain:

:tup: Thanks to fatherbrain for the great guide… dood!

Port Forwarding

Original thread [here]:

From djfrijoles:

:tup: Thanks to djfrijoles for the great guide… dood!

having some trouble with 2df, I am using my laptop. it has vista, the program starts up fine but once a game starts the framerate can get pretty ugly. is there any specific video setting I should be at to fix this?

i did everything it said and i still get the “wrong username and or password” pop up even tho i input both correctly on ggpo login. could it be windows 7?

i cant register for It gives me this error, The entered e-mail domain has no valid MX record.
help pleasee

use a different email address, like gmail


Can anybody help me understand how to get into Godweapon east coast kaillera server?

I haven’t played online using Kaillera in a few months and wanted to get back on. I can’t connect!!

Anybody else has had this problem or knows if the server is down?

I got a GGPO question, how good is it in Windows 7 64-bit? Is it optimize or should I run the program in compatible Windows XP SP3 mode?

I can’t get GGPO to work since I’ve had my new pc with vista. had no problems on xp. i changed compatibility mode, open the correct ports, port forwarding, u name it and I still can’t get passed the login screen. Can anyone help me?

i can use ggpo with no problems with my W7 64 bits, you don’t need to do any funny stuff to play on ggpo.

for your own good, please stop using Vista, if you don’t want to use XP again, install W7.

i dont get how the port fowarding works s

Hey, I’m kind of in a stupid situation.
I know how to port forward, did it on several computers and routers. I got ggpo to run perfectly on my current notebook. The thing is, I’ve moved to a different university, so my only internet access is through here. Ever since then I’ve been getting the “connecting to server” screen and nothing happens, so I can’t play. The problem is I can’t just open ports here, does that mean I’m stuck with this?

I’m running Win7 64bit, updated .Net, GGPO, Adobe Air and whatnot. It’s worked before so I guess it just has to be the port thing, since nothing else has changed. Any help appreciated, this really sucks.

had a question about playing online on your pc… I once did it before without any problems with friends p2p nfba and 2df… then in the middle of a game with a friend on 2df i start feeling a sudden input delay, dont know if it was movement on stick or buttons…

since then, ive always felt it with all emulators and sticks ive tryed… ive tryed playing with ps2 stick and madcatz SE and TE stick, even offline play on the emulator is the same… take ken for example, its like he takes a half/whole step foward before he does the srk when I do the srk motion, and its very hard doing a super after a chain…

first I thought it was the stick, but since all sticks and all emus (online and offline) im starting to think its my computer? something with the motherboard or the usb-ports maybe? does anyone know what it can be and how I can fix it? answers very appriciated… thanks…

Anyone can help me figure out to use a Xbox 360 pad for Supercade?