Terminal Strip Connection Problem

I have an SE stick. I recently got a replacement JLF wiring harness, because the Madcatz harness wouldn’t stay clipped on, and thus wouldn’t register commands.

Now, I’m connecting the old harness to the new one through a terminal strip. The problem is, only one connection is working - down (red.)

I can’t get the rest of them to work. Can anyone help?

why didnt you just put a dab of hot glue or some electrical tape on it?
make sure you have the colors on the harness correct with the orientation of the jlf. heres a reference

I have the orientation for the wires correct. My problem is that they will not establish a connection, no matter what I do. I’ve tried connecting the wires in every way I could think of and putting them in the terminal strip (which is made of conductive metal) but I still get no connection from anything but down (red.)

Are you sure the wires of Sanwa JLF-H is connected to correct respective wires of Mad Catz Harness?
Because that is the same problem when connecting Mad Catz Wire Harness upside-down to Joystick; only Down will register.

You test with individual Directions?
Let the Down of the Mad Catz go to another direction of the Sanwa.

Test to see if work.

Okay. I’ll give that a try soon and get back to you.

All right – I did what you suggested, and now every direction works… EXCEPT down. It will only work occasionally. What’s the problem now? Will the “down” command just not work properly with my JLF? I had this exact same problem before, and I was instructed to get a JLF wiring harness and a terminal strip.

It doesn’t do this with the stock stick – which, by the way, I can’t put back in, as I mutilated the harness to put it into the terminal strip.

Edit:// Nevermind. It was the pin connection. I just stuck a kneaded eraser under the connector to hold it up and it works fine now… well, FOR now.