SSFIVAE: button stops working in online match

Hoping someone might have an idea here. I have a brand new xbox 360 wired controller that works perfectly. In SSFIVAE right after I hit “ready”, about half the time, the bumper button that I have assigned to light punch and also “start/advance” etc stops working. If I cont/alt/del it works fine, its only in the game. After minimizing then maximizing the game, it will work again, but usually only for a short time. Any ideas on this? Its only happening in this game, no problems at all anywhere else.

More details Please?

Are you using a Xbox 360 or a PC?
if you are using a PC, What is the OS? Examples Maco OSx, Win Xp, Win 7, Debian Linux, ect…

Hey Darksakul:

Basically I have been playing on Steam/PC on windows XP for almost 500 hours with no issue whatsoever and I used this particular wired controller, which is new, for a few months with no issue. I purchased a new video card and did a complete reinstallation of everything, OS included. I installed GFWL and everything else has been fine… aside from now with the gamepad in this game only. I am wondering if it isn’t a power issue, as the old video card had 2 PCI power connectors, whereas this one has one (direct power connector to the power supply) and then gets some power possibly from the motherboard, and I also think that this video card may use more PCI processor bandwidth. So I am thinking that maybe once I hit Accept to accept the match, that the ethernet card maybe kicking in fully and this maybe somehow now allowing enough bandwidth or processor I/O allocation (?) for the USB connected controller and that is causing the issue. I’ve done most obvious things, changing to a new USB port, D/C’ing the mouse and keyboard so the gamepad is the only USB device connected etc, all to no avail. I’ve contacted CAPCOM and GFWL (a few weeks ago) and no response from them. Strange issue I know but any idea you have would be appreciated, as it only seems to happen once I enter an online match… outside the game and in single player there are no issues at all with the gamepad.

That’s indeed strange… Try:
1.) Plugging the stick into a powered USB hub, if you have one
2.) Setting Steam to download something big, then hopping into joy.cpl to see if the buttons still work (Steam eats all of the bandwidth, so it’s a decent test)
3.) Turning off any button remapping software, if you use it
4.) Switching to a different network adaptor, if you have one

I am starting to think maybe its a power issue… I think once the Ethernet card kicks in fully maybe the gamepad isn’t getting enough power. I’m gonna check out powered USB hubs, I don’t have one at the moment. Any other ideas appreciated and thanks for the help.

I do not think that is the correct diagnosis, I can’t wrap my head around how the ethernet card would knock out the keyboard mouse and arcade stick. Even with a More powerful Video Card.
As at point when the Video card gets “too big” for the rest of the PC the Video performance will “bottleneck” but it shouldn’t effect the Stick.

I basically have a form factor case and my last video card was an 8800GTX that had 2 6 pin connectors that went directly to the power supply. From my understanding, this new video card A) possibly draws some power from the motherboard in addition to the single 6 pin PS connector, and B) uses more processor bandwidth I/O allocation. I am not completely sure what that is but I know that each device connected to the motherboard, including all the USB devices, PCI cards, i.e. the video card, the sound card, etc, share something to the effect of I/O Allocation resources. So I am thinking that this is what is possibly going on… unless its an issue with GFWL, which is also a big possibility. I think its most likely some issue/bug with games for windows live, and if its not that, then it has something to do with what I said. If that means anything to you feel free to expand on it, and thanks again for your help. As of now I still have the issue and its making me not want to play SF anymore :frowning:

I don’t know the details of it but I know that all the devices share processor I/O allocation, including the ethernet card, the PCI video card, the PCI sound card, the mouse, the keyboard, and all the USB devices that are attached. In device manager you can see what percentage they each use. I am thinking that once the ethernet modem kicks in fully, i.e. when I hit “accept” in the match up screen, that may be cutting off resources to the USB xbox 360 controller (btw its just a 360 controller, not a stick). Anyway if you have any ideas don’t hesitate to let me know, thanks.

"all the devices share processor I/O allocation"
Yes and No.

Its kinda hard to explain, There are 2 sets of allocations. One a High Level (North bridge) and one low Level (South Bridge) For technical reasons I tell you that Not all Motherboards have a formal north and south bridge any more, but for theory of how the PC works I stick to the Northbridge southbridge scheme.

Think of bandwidth inside like roads, and packets of information are like cars.

Video card and ethernet is a North Bridge connection with a higher bandwidth (like a huge interstate multi-lane highway)
Mouse, keyboard and arcade sticks should be a Southbridge (fewer lanes, lower speed on the speed limit sign like a 2 lane country road)

The Video card can only take what the motherboard gives and nothing more. If the Video card supports more bandwidth than the motherboard offers, its limited to the motherboard’s bandwidth.
When the Videocard can do more than the motherboard allows, thats called a bottleneck. Bottlenecks can exist on other devices on the PC as well.

So by this theory it should be impossible that your ethernet card kicks off the arcade controller.

Also do not confuse data lines with Power, your video card primarily gets power off the Power supply connector it has not the motherboard. Lower end Video cards without a power supply connector gets their power from the motherboard.

The lag is either being generated by one of several things.
Lag in the CPU, CPU cycles waiting for ethernet packets to proceed, Overheating, or your Power Supply unit can’t deliver enough watts to your whole system.

Do you know what Power Supply Unit (PSU) you have and what it is max Watt rating?
What Model and version of Video Card do you have and what’s its required for power in Watts?

This sounds like it could be it. But its a fast processor (3.8 ghz) and I never had any issue with it till now. And having just reinstalled the new video card I know there is no dust or build up. Also, it seems that I am playing many more processor intense games such as Witcher 2 at max settings with no issues at all with the gamepad. I monitor my GPU as well as the processor to see how the games use them, and I can see that Witcher 2, which I also use a gamepad with, fully utilizes the processor and the GPU (no other game does this). Regarding the power supply, I’ve been down that road, and its a 700 watt… and only a few months old. The current card only asks for a small amount (65 watts)… But this does raise an interesting issue in that the new video card uses half the power of the last one… the 8800GTX had two 6 pin connectors and used like 150 Watts, and yet this video card performs just as well. Also EVGA told me that some of the new video cards (since they require less power now and are much more efficient) can actually run off the motherboard, or draw some of the power through the motherboard and then supplement it with the single 6 pin connector.

Anyway I finally heard back from GFWL and he told me to reinstall the game, since it appears that the controller is working fine. So doing that now through Steam, I’ll keep you posted. Thanks again for your time/assistance.

Reinstalled and no dice. I have definitely isolated the problem … it only happens right after I hit “ready” in the match up screen. And then all through the character select screens and the match, whichever button is assigned to light kick/start/advance stops working. Immediately after the match completes in the results screen, it starts working again.

EDIT: I set the controller back to default and it worked, it seems its only the two bumper buttons that stop responding in online matches when they are set to ‘light kick/confirm’. I switched the triggers and the bumpers around and it worked, so it seems like its the bumper buttons that are the culprits.

So wait, do the bumpers still work when not reassigned?

yes, it seems the issue only happens when the start/confirm/lightkick button is assigned to one of the bumper buttons

In case anyone comes around with this issue… I just got a new controller and that fixed the issue… so apparently it was the controller I guess.

What was your old Xbox 360 controller.

My friend had the same issue while using the Tekken 6 stick on his pc. He ended up having to use a different stick, but once he went back to try using the Tekken 6 stick again it magically worked.