SSF v0.08 R11 (Can't Configure Keys)

Does anyone have or use this Saturn emulator? I can’t seem to configure my keys, wondering if it’s a DirectX issue and the fact I’m running Windows 2000. Any help would be appreciated. This is the only emulator I’ve found that runs game from the get go, and does so very well. I just really wish I could get my gamepad working.

P.S. The key config just shows a small window named “redefine keys”, with no text in it and it just sits there laughing at me. What should I be seeing? and how is it supposed to work (screenshots might be helpful).

change regional settings to japanese or use applocale.

Tried that with no luck…

After clicking redefine for player 1 here:

I get this dialog:

and it just sits there, I have to ALT-F4 just to close that tiny window.

I also noticed this message?

after changing my region code… not exactly the most descriptive error.

*** UPDATE ***

I updated my DirectX to 9.0c June 2007, that didn’t help. So I decided to start checking older versions of SSF as I knew this was working before at some point. Turns out between v0.08 R4 and v0.08 R5 something changed. R4 pulls up the little window and asks me for inputs, while R5 and later just give me the blank dialog. However R5 and later work just fine under XP. So I believe this is a 2000/DX issue. If I find a suitable solution for 2000 users (and not just using Joy2Key) I’ll post again.

Wow, now I’m totally confused.

I tried R11 on sperate Windows 2000 machine (only difference being it was SP4 with no hotfixes, previous test machine was SP4 with all hotfixes) and everything worked… I’m going to dig into this some more, I’m sure you all care :xeye:, and once I find out the exact reason this is happening, I’ll post again.

P.S. I still believe it may be a DirectInput version issue.