[Solution] USB Device descriptor request failed or Port reset failed error

I am writing down this guide in order to help those who are or will be facing this trouble which haunted me more than a week. I will try to keep it short and simple and to the point, so here goes.

For what information I have gathered, it only happens on the 360 sticks on either windows 8.1 or windows 10 (for me win10) and most probably you have dual modded stick. I think it has something to do with the voltage of the usb port and the PCBs not being regulated probably.

First of all install the xbox 360 and xbox one controller drivers (which ever pcb you are having problems with, I was having problems for the PDP Mortal Kombat X Fightpad for xbox one and xbox 360 both sides).

Xbox 360 wired controller drivers for win 7 for 32-bit (works for win 8/8.1/10 as well).
Xbox 360 wired controller drivers for win 7 for 64-bit (works for win 8/8.1/10 as well).
Xbox one wired controller drivers for 32-bit
Xbox one wired controller drivers for 64-bit

Once you’ve installed the appropriate drivers, go for the Fixes mentioned below. Different people will have to apply different Fixes to make it work so I’ll post by numbering the Fixes starting from 1 and onwards. Plug in your arcade stick on xbox 360 mode and start following steps.

Fix No. 1:

  1. Right click “My Computer” and click “Manage”.
  2. In computer management, Click “Device Manager”.
  3. In devices, click the side arrow on “Universal Serial bus controllers” to drop down the list and uninstall the yellow exclamation mark i.e. “USB Device Descriptor Request Failed” or “USB Port Reset Failed” or something similar.


  1. Restart PC.

Fix No. 2:

  1. Right click My Computer and click Manage.
  2. In computer management, Click “Device Manager”.
  3. In devices, click the side arrow on “Universal Serial Bus Controllers” to drop down the list of USB Hubs.
  4. Depending on computers, it might say “Generic USB hub” or “USB Root Hub”; you should have 4, 5 or maybe 8 of them listed. Right click starting from the last one, “Update driver software”.


  1. Click “Browse My computer for driver software”.
  2. Click “Let me pick from a list of device drivers on my computer”.
  3. Re-select “USB Root Hub” and click next.
  4. Click close.
  5. Do this for each of the “USB Root hub”.

Watch video how to do above.

It should detect your 360 arcade stick by now. If not then you might have to do Fix1 and Fix2 both respectively same as me as I have to do both that too consecutive times in order to make it work.

Fix No. 3:

  1. Unplug the power cable from the CPU and let it remain unplugged for at least 5-10 minutes.
  2. Plug the cable back in and start PC.

Fix No. 4:

  1. Update your BIOS.
    Reset your BIOS.

  2. Update your Generic USB drivers.

Fix No. 5:

  1. Change the USB cable of the arcade stick (I would not recommend that).

Let me know what worked for you from these Fixes or if you tried your known fix and want to help others. Thanks.

Get a USB repeater from Monoprice

I get this problem with a short cable so this wouldnt help.

I think the optical PCB I use for my joystick is causing this problem on certain USB ports on my PC.

When I switch out the optical for a normal JLF microswitch based PCB I don’t have any problems on these same USB ports.

I use the PS360 PCB btw. I’ve tried Fix 1 and 2 without any success about 2 weeks ago. I’ll try fix 3 right now and report back, although I suspect that its my USB ports not being able to properly supply enough power for my optical joystick pcb + ps360 pcb.

i said “repeater” not “extension”

Also are you using the optical on the Kuro? Might have to talk to @Gummo about what he did for that one

Just to add what Vicko said:

An extension is just straight wire. It’s like getting a longer cable.

What Vicko talking about, a Repeater isn’t just an extension. One end of that cable is packed with electronics.
A Repeater literality repeats all the signals and give the signals a boost going both ways allowing USB cables to go pass their maximum length.
Think of it as a signal booster for USB.

I was under the impression that you would need a repeater to extend the cable past 15m. If im using only 1m of cable and getting this problem, would this help in anyway? I seriously dont think so.

IIRC, Toodles mentioned in the sparkCE thread that the Flash 1 optical had problems with the ps360, I’ll try to find the post to make sure though.

Yes, for some reason sticks just don’t work on PCs nowadays, especially on 8.1 and even more so if dual modded. I have tried it myself and for other customers that have confirmed this has worked. I wouldn’t recommend it if it didn’t work.

Ok, I’ll consider that an option if my SparkCE doesn’t work when I get it tomorow.

But here is the post I was talking about, maybe you can make more sense of it than I can.

Both of my sticks work fine on my PC since 4 years now. I’ve been on windows 8, 8.1 and now 10. The ps360 pcb does not work on 2 USB ports on my PC when I have the Flash 1 PCB installed. Works fine on the other available USB ports but not these two on the face of my PC case.

I’ll look into buying a repeater if this SparkCE doesn’t solve my problems.


Been meaning to ask this, would a Powered USB hub serve the same purpose as a repeater?

Where are you soldering your VCC? I know once I soldered onto the ribbon for the turbo panel and it caused a similar issue. Are you soldering directly to the USB VCC (red wire)?

I’m using a PS360 pcb, no soldering required. I simply connect it to the VCC hole and screw the terminal down.

It can be even worst on Windows 10, as the New Win 10 Xbox App will reject all game controllers that are not Approved Xbox controllers, even legitimate licensed Xbox 360 and Xbox One controllers.
Yes keyboard and mouse still works

When I tried fix 1 and 2 separately, it didn’t work for me either but when i tried both fixes at once, it worked. Then the next day the error came back and i had to try it several times to make it work. It comes back again every now and then.

What vicko suggested is a good device and fix but I do not want to spend anymore money.

$10 for a sure thing? That’s 2 Starbucks lol

$10 is $14 australian and is still money which I managed to save.

Just to report back, I switched from a Flash 1 Optical JLF PCB to a Toodles SparkCE Optical JLF PCB and it fixed my problem.

I can now use my USB ports on my front panel of my PC.

A quote from Toodles here

I was using a Flash 1 JLF PCB with a PS360 PCB and was having connectivity problems on some of my USB ports on my PC. When I switched from the Flash 1 to the Spark CE, the problems went away.

Thanks OP! Fix 1 worked for both of my PS3 sticks on Windows 10.

One was listed as “VIA 5 USB…” but uninstalling the “yellow triangle” and restarting did the trick.

  1. Update your drivers.
    1. Disable fast boot.
  2. Make sure USB suspend settings are disabled.
  1. Buzz off, bot.

If you suspect a bot just tag @d3v

Users of windows face device descriptor request failed error. There are 3 types of efforts. First users only see the yellow warning with device error in device manager. 2nd Deice is not working, 3rd Your device is not working but status of device is positive. You can get the solution here https://appuals.com/device-descriptor-request-failed/ using different methods. A complete case study with solution have this site.