Soldered usb buttons working but joystick not (SOLVED!)

i have looked everywhere and couldnt find an answer. i have an xbox 360 madcats TE stick that had a cut cable. i have stripped and soldered it back together but for some reason the joystick doesnt work but all the buttons do… any ideas? thanks in advance.

Take clear pictures of the insides to show us what you did, and then we’ll be able to help you out.

sorry, i meant the usb cable. I have soldered it twice and both times have come up with the same problem. thats just got electrical tape on it to test.

i have not actually opened it up before bacuase of the glue :confused: the whole stick worked fine before the cut so i didnt think it would be a connection inside.

you probably moved the switch to RS. It’s located above the lock switch of the TE.

PheNOM07 you cheeky devil you have sold my stupid ass problem in one swoop. god thank you i feel silly now haha good to know my soldering job wasnt a botch. cheers again to both of you guys :slight_smile: