Servers randomly come up at over 1000ms

I have no idea why, but lately on random days, like 90% of the servers will come up at 1ms and I won’t be able to join any of them.

The only 2 that are never affected by this are GodWeapon and Sonic Cage Dome.
Don’t suppose anyone else has this problem.

I can’t even join private servers (not even my own) when this happens.
It sounds like a port issue or something, but even with all my ports open, nothing. I just have to wait it out.

Something like this happenned to me a while ago; my average ping was around 500~ ms and I had lower ping in European servers than American ones Oo;;

I never understood what was wrong, so I just waited it out, and it eventually (few weeks) dropped.

I just have randompingsd at some places. Like GW says it 110 for me but when i log in it’s ~60.

Actually the only servers that don’t jump around on me are Fragbox, A3d and Dar0ms.

yeah something weird like this happened i came on godweapon like 4 weeks ago and my ping changed from 78 to 139. Now its 133 and it won’t go down. :sad:

GW=Emuliinker and 139 ping…your world is so harsh =/
You should start playing on private servers.

That’s just it. I can’t join any anymore.
Every server except SCD and GW come up at over 1s for me.
Same goes for my own private server.

If you’re routed, did a recent firmware update possibly cause this? Or perhaps an update to a software firewall?

Haven’t touched the firmware.
Only difference firewall wise is that I’m using the SP2 firewall now.
I’ve tried disabling it though and no go.
Even tried setting the router to DMZ. No change.

This is…selective disturbance. Its most likely your firewall or something similar. Have you tried it without firewall? You should not need firewall with xp if you have all the security fixes. If that does not make it any better, you could try connecting directly (i.e. disable router wan and set up a new connection to connect to your isp from your computer).

Connecting directly to the modem isn’t an option. 3 other people in the house get their internet from this computer.

what about firewalls of your router?

The router blocks ports by default, but you can set it to DMZ to open every single port on the router.
I tried this, but it didn’t help.

Ok, now my ping is 141 in godweapon omg! :arazz:

Yeah, something like that’s been happening to me. Before in GW, I used to have a ping of around 71-78 now it jumped up to 98 to sometimes even 121!

can you connect to this server: ?

If you cant…do a traceroute on . You should be able to see where the packets fail.

I fixed it a while back.
Turns out if you forward a port on a d-link router under virtual machine and then set it as a trigger port as well, it acts as if you didn’t open anything in the first place.