Sata hard drives not detected in windows xp

after re-installing windows xp my sata hd’s aren’t being detected. my ide drives are fine and booting windows, but bios shows one of the sata drives and i still can’t access it in windows. my computer specs are:

  • epox nforce4 motherboard… 9npa3 ultra
  • dual core amd opteron processor 165
  • 2 gigs ram
  • 2 sata drives
  • 2 ide drives

any ideas?

I believe you need a driver for SATA HDDs in Windows XP. I have a SATA HDD and I can’t even install XP on it without loading the drivers beforehand. Find the drivers and your problem should be solved.

i checked the epox main page and there are no sata drivers available… this is ridiculous cause literally a week ago i was running everything fine. and now i’m this close to losing just under a terabite of data… i reset my cmos a second ago with no luck… switched the slots repeatedly… no luck

It is almost surely a driver issue. The last couple motherboards I had all needed drivers installed for sata.

Mobo? I always thought it was an OS issue because I need drivers if I want to install XP, but I can install Ubuntu without any problems.

Have you tried importing the HDD using disk management? Just go to Control panel (classic view), go to administrative tools, then double click computer management and look for disk management using the folder tree at the left, it should give you a list of every single drive installed at the bottom-right part of the window (includig CD/DVD drives and removable drives), just look for the disk the matches your HDD size and right click on it and then select import. If you deleted the partitions on this HDD during windows installation then you’ll need first to allocate the drive, then partition and format it (right clicking as well from the disk management window) hope it helps.

i’ve tried that too… and only 1 shows up and its all unallocated hd space…

search in google “sata xp cannot install” or similar. Had the same problem myself. Couldn’t resolve it since my specific hdd manufacturer doesn’t make drivers for it.

have you tried the nforce4 drivers from nvidia’s site?

i just need to know are your hard drives in raid?

did you even consider flashing/updating your mobo bios as well?

Check your bios and disable Native SATA.

windows xp unfortunately doesn’t have the drivers to run native SATA drives so disable it in your BIOS.

If u have a floppy disk drive you can probably find some drivers, put it on floppy disk, and press F6 while the blue screen windows xp setup is starting up to load up RAID drivers.

If u can’t find a native SATA option, ignore this reply.:rofl:

no sir. epox hasn’t made any updates so i lose there. and my drives aren’t in raid james…
and nvidia’s drivers aren’t doing anything for them. I have xp installed so the issue is just getting the sata2 drivers so i can get my data back.