Really weird problem with SF4

I have just finished wiring my xbox 360 wired pcb for use in my new arcade stick when i ran into a very weird problem. All the buttons fire correctly and i can use all of them except for with SF4.

When i am in a match I none of the buttons assigned to kick will work. I have A set for light kick, b set for medium kick and right trigger set for hard kick. These buttons work for everything else just not for SF4.

Now this only happens when I have the setting for custom controller but when I set them controller type A,B or C they work just fine. The way I have the buttons laid out I woul like A to be light kick and b to medium kick but it just won’t work because I have to use the custom controller feature. I have also tried switching the controller to arcade stick but that doesn’t help either.

Please if anyone has had this problem and can help me it would be much appreciated.

Same Problem

I’m having the same problem. I can use those same buttons (a & b) for anything other than medium kick and heavy kick. It’s driving me nuts. Anyone have any suggestions?

Xbox 360 wireless controller
Happ Controls buttons and joystick



What’s wrong with the standard arcade layout? It’s the most efficient. If you can be swayed, I highly implore you to not customize the button mapping.

turn off your 3 kick button

see if it fixes things

if so you fucked up your trigger.

It worked!

I disabled both triggers (in the button config menu) and the kicks now work!. Thanks!