Razer Atrox not detected in Steam Big Picture Mode

Hi all,
I recently picked up a razer atrox arcade stick but it won’t work in big picture mode. I understand that there’s limited controller support in BPM, but I was hoping it would work given it uses the standard Xbox 360 controller drivers in Windows. I have a wired and wireless 360 controller too which work great in big picture. The atrox works fine in games launched from big picture mode, it just can’t be used to navigate in BPM. The controller menu doesn’t even detect it. I’ve read there are people out there using 3rd party xbox 360 controllers successfully in big picture including the mad catz sticks, so if anyone has any tips or workarounds I’m all ears. I’m currently awaiting a support ticket response from steam, so if they can help I’ll post the workaround here. I also contacted razer but they just told me it wasn’t their problem.


Using a console stick on a PC is always iffy. And manufacturers will always claim it not their problem as you are not using the product as they intended.

Try this and see if it works.
How that is said, try uninstalling the Razor Atrox stick from windows. When you Re install the stick, do not let windows choose the device drivers.
Use the Microsoft Xbox 360 WIRED Controller driver for Windows, the driver for the MS Wired Xbox 360 controller Pad.

Thank you for your response. There are 6 xbox 360 drivers available and I’ve tried all of them to no avail unfortunately. I’ve tried them on both win 7 and win 8 machines.