Qanba carbon won't connect anymore

So just recently, my carbon fightstick was working just fine until all of a sudden, it just stopped. It gives me a notice saying “USB Device not recognized” when i plug it into my pc which leads me to think that it my just be the usb wire but im asking here just to make sure if there’s more to it. I’ve also tried on my ps3 and still no luck. Any thoughts as to what the problem could be?

Have you tried changing it to X input mode?

Should’ve mentioned before that I managed to get it fixed and working. Had to replace the USB cable with a new one. still thanks for trying to help.

Do you mind explaining how you changed the cable, like did you just get a new cable and plugged it into the PCB? I have a Carbon myself and would like to know just in case this happens to mine.

You’ll have to open up you fightstick and from there you can just remove the cable from the jst slot on the PCB. as for finding a replacement USB cable, Arcadeshock sells them for $15.