Ps360+ Question

I have a ps360+ in my VS stick and there is a cable with rj-45 jack so I can play dc, xbox1 etc and also there is a usb cable connected to the board as well. The board won’t pick up on older systems with jack but usb cable can play ps3 and 360 just fine. I am wondering the older systems are not registering because there are two cables and it is confused? I have already updated latest firmware and have tried to manually set systems up with button configs with no luck. Help would be much appreciated.

Do you have the appropriate RJ-45 to DC/PS1/PS2/XBox cables?

Yes I have all the cables for the systems and I know they work because I also have another stick with a kitty in it and it works perfectly with all the systems

Do not have both cables types connected at the same time, use one or the other. As a sanity check, remove the neutrik if there is one and go directly to the board with the RJ45-whatever cable.

ok. thank you!

So I took out the other cable and left Rj-45 and it works on the ps3, & ps2 so far and not the 360. I have tried to force mode to 360 using aki-shops guide. Suggestions…

Have you tried updating to the latest firmware? I’ve had issues in the past where it would connect to PS3, but it had issues connecting with certain xboxs and PCs.

Try force mode first though. Hold the 2nd buttom from the left on the top row of buttons WHILE you plug it into the xbox. This forces the PS360+ board to go into Xbox mode, bypassing the auto-detect stuff.

If that doesn’t work, update the firmware. Instructions are on the PDFs available at akishop’s website.