PS360+ Major problem

Hello everyone,

Yesterday, I finally received my PS360+ after a month of waiting. Yesterday, I decided to do some initial testing with it via the RJ45-PS2 cable. It worked fine. I even upgraded it to the latest firmware to improve functionality.

I originally bought it to mod my PS3 TE-S stick. I didn’t want to spend any more money buying a RJ45-USB cable so I decided to reuse my TE’s USB cable and solder the points. To my biggest regret, it didn’t connect to my PS3 and now the stick won’t even be recognized by the PS2. I tried re-updating it, but as soon as I plugged it in, the computer decides to screw up as it was doing the boot loader thing, and it claims that the PCB has malfunctioned. :frowning: Now I can’t even upgrade it to make sure it works.

I tested for continuity, and nothing was wrong. So what was wrong??? Please help because I don’t wanna send this back and wait again!!!

  • Jade

Can you post pics? Or did you remove it from the stick?

I didn’t remove it from the stick. I’ll post pics in an hour or so. Basically, when I plug it in with the start button held down, the LED lights flash back and forth. However, the windows xp I was using at the time isn’t recognizing it.

I updated it originally with the windows 7 in my bedroom. I didn’t want to go back upstairs in since it was very late last night and I was doing most of the work in my basement (where the xp and ps3 is).

EDIT: Okay, so I plugged it into my windows 7 with the start button held down. The LED lights are flashing but the computer is not recognizing it. I didn’t hear a sound when it plugged in and nothing on the screen is popping up. Now I fear that it did malfunction.

This is the message that came up on the xp computer (when it happened):

I have had similar problems, and its usually the usb connection, make sure all the cables are soldered to the correct connections and not linked. i often mix them up because i solder to the bottom of the board. so make sure the its G: thin black wire, D- : White wire, D+ : Green wire & the V: red wire. hope this helps.

I tried that. It still was no good.

If you have both the RJ45-PS2 cable in place and the USB cable soldered in I’m guessing that’s your issue. Since the bootloader is burned in via the ISP, you can’t corrupt it during a firmware flash (which is indicated by the LED’s flashing back and forth, so the code is running), so this is a connection issue.

Remove the RJ45 connected cable and try on USB only, if that still is giving you shit, remove the soldered cable and plug in via USB B ended cable directly to the USB plug and try, I’m betting that will at the least work.

Oh My God! Thank you guys so much. I desoldered all the USB cable wires from the PCB. I unplugged the RJ45 cable from the PCB but left it connected to the Neutrik jack. I plugged the USB cable directly from the USB port of the PCB into my laptop (which hasn’t had any experience with PCB yet, i did install the necessary stuff beforehand) and it installed perfectly as the PS360+ 1.3 game controller. This lifted my hopes.

Afterwards, I disconnected it from the laptop and replugged it in its boot loader form. Then i did everything else and it was read by Amtel’s flip program.

Then came the moment of truth. I plugged it in my PS3 and boom! It worked. I could navigate the XMB! And I tried a couple of games with it. Then afterwards, I tried it on the PS2 (forced mode) and boom! It worked. I just wished it worked with tekken 5 though, but atleast it worked with SNKvsCapcom 2 and KOF11.

All is well now. I just ordered the Rj45 to USB cable since a direct USB connection is a no-go (and neither is plugging in the PS2 cable with a PS2/USB adapter i have.)

Thank you all so much! :slight_smile:

  • Jade