Ps3 te modded with 4716 pcb and imp . XBOX side is not working right

Okay so I modded my ps3 te with a imp board and a xbox 4716 pcb. The ps3 side works fine but when i try to use the xbox side (via switching to rs) only the guide and d-pad works. Start, select, and all kick and punch buttons don’t work. I only wired one ground wire from the 4716. I followed all the tutorials on here 10 fold. Am I supposed to wire another ground wire from the 4716? Do you guys know what is going on with my stick? Please i’m in desparate need for your help.

pictures help greatly you know

Alright, calm down, take a breath, and get ready to troubleshoot. As stated, pcitures are helpful, but let’s try a few things. First thing is to plug it into a PC, open up your control panel, go to printers and other hardware, and open up the properties menu of your controller (in 360 mode, of course)

My guess? You might have connected to the wrong side of the terminal strip, which may cause some funky problems. Again, pictures are nice. Show your wiring, your soldering, your PCBs, full shots. Details. Better to over show than under show.

Did you wire all the buttons to the pcb ? Sounds like you only wired the imp

I don’t know why but I have a feeling that he’s not using a trigger inverter for that 4716 pcb either…

I’m sorry for not posting any photos. I’ll try to get those to you. I used the resister method (low to wiper wiper to high) I didn’t forget to solder the buttons on the pcb lol. Instead of soldering to the terminal block I soldered the wires into the quick disconnects that connect to the terminal block. I’m using a 6 button config and none of the kicks or punches work. I will connect to my pc to check on there. I didn’t use a trigger inverter since I disabled the triggs via resisters

Okay, then its probably the problem that nerrage had stated where the signals are swapped with ground for buttons. Try trading the quick disconnects of one button’s signal and ground to the terminal block. Test it on pc and see what happens

Okay. You put your wires in the barrier strip? Make sure that they all go to the row that is on the top, not the row that is on the bottom. The bottom row is all ground, you need to connect a ground wire there, and then connect the button signal wires to the row that is on top. Since you soldered them on, if they’re backwards, simply unplug the old wires, and swap the bottom one for the top one.

so i plugged it in my pc and all 8 buttons on the pc show up as active (red) so i do need a ground wire wired there? I though only 1 ground was needed since it is a common ground pcb? I’m so grateful for all your help. I’ll try your recommendations and see what happens.

Since they’re all active it probably means you wired the button leads straight to the ground, if you’re using a terminal strip it should be as easy as switching all the wires around

You have a ground wire touching all of your buttons. If swapping sides doesn’t work (Which I believe is the problem), what’s best to do is to just disconnect everything, and start with one button. Connect it to the top side of the terminal strip, and try it. If it works, move on, if it doesn’t, keep looking for the problem. a mistake on your soldering or a loose wire could cause all of those problems.

But because all 8 are active, you’ve probably just connected it to the wrong side, which causes them to all be read as active, so try that first.

holy crap! i just opened my stick and guess what? all the wires are connected to the bottom haha! Man you guys rock, i can’t believe i overlooked that step. I’ll let you know if it works after i do the switch. brb!

man my fingers are hurting trying to pull these damn things off. I need to go get some needle nose brb lol

Ok now all the buttons work! Yay! BUT! Now my guide button doesnt work : (. It worked when i plugged into my friends xbox a while back. What do u think?

I think it’s unrelated to the terminal strip, and that you should check the wiring and soldering to make sure everything is properly connected and okay.

I have a feeling you’re trying to test out the guide button on the PC.
Guide buttons don’t work/register on PC in the game controllers section where you test inputs. They do work with games that are associated with windows live. Test it on a windows game or test it live on an xbox.

I understand, but why did it work when I had the wires in the wrong place? I mean i can live without the guide button since the other player can use his guide button right? Other than that, thank you all for your help. I really appreciate it.

If you have the Microsoft software installed you can bring up a small window which shows you which player you are and battery life (if you’re on a wireless controller) with the guide button.

That explains it! Man you guys are smart! I can’t thank you enough. A few weeks ago we had a tournament at my friends house. About 12 of us. I took my stick all excited to play and my buttons were not working. My night was ruined! lol. But now I’m stoked because you guys really made my night. Thanks again!

BTW here his my fight stick. I know its not the inside but we fixed it without the pictures right?