Ps3 Fightstick not working on PC

I’ve recently gotten Street fighter 5 for PC and decided to try to dust off my old ps3 fightstick (that also worked on ps4 for Sf4), but it doesn’t seem to be working. The PC detects the stick itself as PC USB Wired Stick 8838 but doesn’t actually detect the button presses or the joystick at all. For reference I’ve got a PS3 Marvel vs Capcom 2 Tournament Stick from Madcatz and I’m using 3.0 ports. I keep getting mixed answers to the question of my stick being compatible, some telling me its plug and play and some telling me its incompatible. Is there any known fix to this? I tried downloading other emulators and other programs and drivers but nothing’s helped so far.

Street Fighter 5 after I forgot what update switched to Xinput only.
So you need a Xinput compatible Device.

The old PS3 sticks are Dinput and aren’t supported.

Also use 2.0 ports, older mad catz sticks aren’t 2.0 they are 1.1 USb which is also compatible with 3.0 ports.

Try using a Brook PS3 to XboxOne Converter for XInput Games and PS3 to PS4 to play on ps4…

i’d suggest changing your PCB cause PS3 Madcatz PCB’s suck a lot regarding compatibility issues and input lag :slight_smile: Depending where you’re from you might find someone here in SRK that can do that job for you


Just use the program I use this on all games that don’t support D-input.

It makes games recognize D-input devices as X-input devices, so your gameplay experience is just plug and play. Look up a tutorial on how to use it.

1 Like

Hey, I’ve actually tried x360ce, scptoolkit, xoutput, and vigem with no success. The stick is still detected but the presses and joystick aren’t working. Would a Brooks super converter from ps3/ps4 to xbone be my cheapest option here?

your cheapest option is changing the PCB inside your stick (using a 360 controller PCB?), but the process itself can’t be done without proper tools and knowledge…

So Brook’s converter is the best option if you can’t solder right now


I have a Brook PS3/PS4 Fighting Board Plus joystick inside an old Mad Catz TE Rd 1 joystick. I don’t have the original TE board in it. I replaced it with a Turbo board from Jasen’s Customs over a year ago. That’s basically an add-on to the Brook Board (that works only on PS3 to keep Turbo, Lock, and Lt-DSP-Rt) so it should not be creating an issue whatsoever.
Sometimes, the PCB gives me a fit because it can be finicky. Other times, the 20-pin harness tends to get loose and they can afford directionals. In the past when I used it with PS3 and noticed it acting up, I unplugged open up, my TE faceplate, removed and replaced the harness and the PCB was fine. Worked fine on the PS3 today, too, after I tested it in Super Street Fighter II Turbo HD Remix when the PC wasn’t registering diagonals.
Right now, it doesn’t seem to want to register diagonals on the PC (using a 16-bit console emulator). I know selecting the Diagonal Option for controllers is SUPPOSED to cure that problem for a joystick that registers as an XBox joystick but it’s not working.
I’ve tried forcing PS3, PS4 mode, and not doing anything and letting the PC read the PCB as an XBox 360 controller. Still no diagonal movement registration.
This all started happening after a FLASH to the latest driver for this PCB. Admittedly, I have not used this joystick in months with my PC and it’s a possible a Windows 10 update has done something with the controller recognition protocol, too. It doesn’t seemed to have affected my Hori PS3, Hori PS4, Hori PS2 (through USB converter), or MC Cthulu powered Agetec joysticks at all. They work perfectly in the classic console emulator I use as well as MAME. [The Cthulu is really under-rated. 10+ years and it’s solid. It works with everything I’ve thrown at it.]
I kind of hope Brook addresses any driver issues because according to my PC, it’s been over 3 years since they updated the driver for the PS3 PS4 fighting board plus. I can get my button assignments and LEFT, RIGHT, UP, DOWN but it’s not doing diagonals in at least one emulator I’m running.
Will update if I ever figure out what’s going on here!

I found out what the problem was with my modded TE joystick!
It’s not the joystick hardware per se but a programming issue.
Some joystick PCBs are read differently by some emulators. For whatever reasons, the Brooks Fighting Board and the 360 controllers can be really wonky on the SNESx emulator.
Before, I had to check a box “Allow Left+Right/Up+Down” to get the darned joystick’s diagonals to register. I had my PC crash and had to reinstall the OS and some programs didn’t perform the same AFTERWARDS when reinstalled. I noticed the Game Genie cheats don’t work for the SNESx emulator quite like before and I had to manually reconfigure MAME (literally change a ZERO to a “1” in a Notepad document!) to register my joystick inputs. The MAME situation was a real head scratcher but, oh well, I found a solution online!

Now, I have to physically fill in the boxes “Up+Right, Up+Left, Down+Right, Down+Left” with actual inputs to get them to read in SNESx! I NEVER have to do that crap for my Hori PS3, PS4, and MC Cthulu joysticks!!!
Before investigating this online, I forced both PS3 (hold 1P or “Square,” then plug in USB cable) and PS4 (hold 2P or “Triangle,” then plug in USB cable) modes with the Brook board and the same issue came up! You can’t get away without setting up the diagonal inputs manually regardless of what mode the PCB sets you up in! FYI: on my Brook board, your lever always reads as a POV stick on PC regardless of console mode. It will never read as DSP no matter how you set you LS-DSP-RS button. And, yes, the button works on my setup. I got the Turbo PCB replacement from Jasen’s customs specifically to retain the functionality of the Turbo, Lock and Digital/Analog stick switch. When you force PS3 mode, your buttons read like a PS3/Hori PCB would BUT the joystick stays as an analog POV stick readout.

I repeat I DON’T have to do this “diagonal input” set-up for the official Hori and Cthulu PCBs in the emulator giving me problems!
At least this issue doesn’t pop up on the PS3. There’d be no fix if it did.
Thank goodness for forums! I’ve had issues pop up with hardware and software that if NOBODY said anything in forums, I wouldn’t know how to fix them or learn it wasn’t really anything I did!
I think the PC basically reads the Brook PS3/PS4 Fighting Board Plus as an XBox 360 PCB… I dunno. By default, unless you FORCE the mode, the PC will register the Brook board as a 360 PCB. The Hori and MC Cthulu PCBs never act up like this with Mac OR PC!