PLEASE help the newb: Why wont the SS4 AE patch work?

I’m super stuck and I don’t have a clue why.

I bought SS4 AE online and downloaded it digitally from GameStop. The download seems to have worked out fine as I can play the game in the limited characters mode off line.

The game asked me to install the new patch which I tried several times unsuccessfully to do. It starts the installation wizard and then abrutly ends and I keep getting this error message when I look at the ‘titleupdate.log’ file:

Launching Title Update: “C:\Users\rburks\AppData\Local\Microsoft\Xlive\Updates\43430fa0\Content\setup.exe” /selflaunch
Could not get ARPINSTALLLOCATION property from MSI with product code. This property must have been set using a custom action. HR:0x00000000
Could not find game install folder
To manually set folder, run: “C:\Users\rburks\AppData\Local\Microsoft\Xlive\Updates\43430fa0\Content\setup.exe” /f "<path to game folder>"
Path: C:\Users\rburks\AppData\Local\Microsoft\Xlive\Updates\43430fa0\Content\TitleUpdate.msi
Args: ACTION=INSTALL LAUNCHEDVIASETUP=1 APPLICATIONROOTDIRECTORY=“Ignore” ABORTLOGPATH="C:\Users\rburks\AppData\Local\Microsoft\GFWLive\Install\Logs itleupdate.log"
RelaunchFromMSI: SSFIV.exe

When I try to do the manual update by clicking on setup.exe or titleupdate.msi I keep getting the same message.

Can anyone help me PLEASE.

Thanks in advance for the help

You should try saying that its the PC version in the thread title. That might get you more help.

Also, I’m not savvy with game pirating security, but I think it might be a bad idea to show the original product code.

Have you tried redownloading, and then reinstalling the patch? Maybe there was something wrong with it? Otherwise I would just reinstall the entire game and see if that fixes the patching problem

I have tried reinstalling the game several times along with reinstalling the patch. I can’t get it to work.

Anyone else with an idea?

Does it matter that the game was downloaded from Impulse rather than being copied from a disk?

Could it be that the game directory is not in the place the patch thinks it should be?

Can someone tell me where the information from the patch gets uploaded to? Maybe I can unzip the file into the right area manually.