Opening a Madcatz SF4 Fightpad

Has anyone done this?

My dpad is screwy suddenly, and gets stuck when I press down or doesn’t even register the input. I’m trying to open it and clean up the contacts and such, but after taking off all the screws there’s something in the middle still holding the controller together.

I don’t want to snap anything by forcing the back plate off, so I’ve been trying to find info on this. Can’t find anything.

Are there any pics or a webpage of someone who has opened the controller? Or has anyone done it?



EDIT** : Blah, I read your problem wrong… Thought you wanted pics of PCB lol

There’s a screw hole under the back sticker/label on the controller. If you press your finger along the sticker you should feel it; if you look at it under the reflection of light you should see it. You have to break through the sticker unfortunately to open it.

Thanks for the pics tho :slight_smile: And for the hole info… I found that, then opened it up, and shuffled the dpad around a bit. It wasn’t dirty at all, but when I put it back together, it worked fine…

Until I went to play my friend. Then it started sticking again :annoy:

I really wish I had a solution for this without having to go get another pad, or wait for them to replace it.

Anyone have any ideas on that? To make the dpad stop sticking?

I think it’s a problem with the controller itself. My PS3 fightpad does the same exact thing, clean from the package.

im using the pcb to build a stick

it seems like it’d be a better pcb to use if you wanted 8 buttons… looks like triggers are easier to do.

i like 8 buttons. the triggers are just like any other button with signal/ground wires and its easy to hack.

Those pics are too small to be useful. :frowning:

i know for the logitech rumblepad, it uses rubber on its dpad.

when it started sticking on diagonals it was because there was a hole in the rubber. covered up the hole and it worked fine. then the hole opened up again i gave up -.-

i’m having a similar problem; the d-pad sticks in the up direction… if i spin the d-pad it corrects the problem for the time being. what do you guys suggest I do? wait it out to see if it corrects itself, attempt to fix or just return?