Need help with a button that will not work

Alright basically I’ve been working on a full sanwa mod of the old school Namco Stick, the yellow and grey one. I hooked up everything and did buttons with quick disconnects and they all worked. Than all of a sudden one of the buttons just stopped working. I figured one of the qucik disconnects came loose and low and behold opened it up and one of them did so I was like. Well fuck this I’m not gonna have this happene over and over again so I got ride of the quick disoconnects and soldered all the buttons directly. However the button that the quick disconnect fell off of isn’t working still.

This is the list of things I’ve done and hasn’t worked:
1.) Replaced the Button
2.) Redid both the solder to the board and the button
3.) Check if it was being grounded anywehre

I’m out of ideas. Ever single button works perfect excpet for just one. WTF?

Connect the non-working button to a different wire that’s working with another button. If it still doesn’t work then it’s the button and not your wiring.

But I already replaced the button with no change. The wiring has now been redone like 3 times. It doesn’t make any sense to me. Why would it work than just stop working?

maybe that button isnt working on the pcb

Seems like putting the working button in it’s place test would rule out the button or the PCB.

This is what I was trying to suggest. Use the process of elimination to figure out where the problem is.

Yeah, I was pretty much backing up that method you mentioned. It’s pretty much the quickest and will eliminate the guessing game of wiring or soldering.

Try the “bad” button on different wires as well…

It’s not the button. People please read my first post, I replaced the original button now 3 times. It’s not the button itself. I know for a fact it’s not that. It’s something else, something weird.

It has to be something with the PC board. But what?

Haha, I re-read that and I’m thinking it came across wrong. I was trying to back you up as well. He needs to start swapping things around because he’s the only one who can fix this (unless he’s in CA and is surrounded by thousands of SRK members).

Let’s try breaking this down then:

  1. Button doesn’t work in it’s original location.
  2. Button works fine in a different location.

What could it possibly be aside from the wiring? If you killed a point on the PCB then you should be able to determine that by hooking up the ‘bad’ wire to a ‘good’ button.

1.) Is true
2.) Is true

If it was bad wiring it would have been fixed during one of the 3 resoderings which involved completely resodering the PC Board, the Button, and using new wiring.

So the question is if something got killed on the PC Board than what and how? Because when I originally switched from quick disconnects to just soders there was no touching of the PC Board.

It very well may be something on the PCB then. Desolder the wire from one of your good buttons and connect bad the wire to it. If it doesn’t work then it’s either the wire or the PCB.

If you suspect it’s the PCB then quadruple check your soldering on the bad point. If it’s a copper pad then see if it has been lifted or looks burnt. It’s not out of the question that it’s dead. In that case you will have to find an alternate point to solder to (assuming one exists).

How the hell could it be dead though I didn’t even touch the PC Board at the start. All I did was clip the qucik disconnects off, cut the wire where the quicks were, and strip and solder. So why didn’t it work? What could have killed it and how?


You’re thinking about this all wrong. You sound like a customer, not a troubleshooter. The only part you’ve tested in the button itself, and no one disagrees with you when you say it’s not the button.

So, start testing the wiring. Start testing the pcb. Follow with your eyes the path from the chip to the button and back, and test to locate where the fault is. Time to break out the multimeter.

And wait a bit longer than 3 hours before bumping your own thread, that’s just spam.

I recommend you check the wires. Got a multimeter? Set it to continuity, put one end of the multimeter on the button end of the wire, one on the pcb end of the wire. Do this for both buttons. This’ll let you know if there’s an open in the wire itself. Sometimes, especially with thin wire or single strand wire, there’s a break in the wire that doesn’t affect the insulation. If you don’t have access to a multimeter, just change the wire completely out and see if that helps.

Does nobody read my posts? It is not the wiring. If it was the wiring one of the 3 resoders with new wire would have fixed it.

No, I currently don’t have access to a multimeter, trying to get one today.

Sounds like the PCB then. Why did it break? Who knows, why does anything break when it does?

Maybe the initial loose connection somehow shorted it out. If it’s not the wires, it’s not the buttons, it’s the PCB. Why doesn’t matter anymore, just get a new one. That’s what I would do anyway…

I don’t think people are inherently trying to be jackasses to you (there’s a ton of replies to this thread). It’s just without actually seeing the PCB or poking around at it it’s difficult to give you a diagnosis.

Yeah. Those are basically the three points of failure. It’s not the button. If it’s not the wire as best you can tell then that only leaves the PCB.

True, but I’d actually suspect its a combination of the two :slight_smile: Since the OP wants to ignore the answers he’s getting and doesn’t want to post up anything helpful like what pcb, which button, how it’s wired, pictures, etc. , I’ll keep my suspicions to myself for now.

It’s grown kind of fun in a masochistic way. This thread is a little too eerily like my job:

Me: Thank you for calling support. How can I help you?
Customer: My e-mail doesn’t work!!111
Me: Okay, what’s your domain and the name of your account?
Customer:, user troll
Me: One moment while I pull it up…
Customer: Can you fix this or not?!
Me: …