My stick is dropping inputs. Please help me debug it

So I have a weird issue with my fightstick that started fairly recently. It’s a Qanba Q4 that I’ve had for about a year. When I put the stick in down-left and up-left positions, it occasionally will not register the left part of the input. Sometimes I tap up-left and get a neutral jump. When I turn inputs on in training mode, I can see it occasionally being dropped. I’ll tap up-left and the input only shows up. Sometimes, when I try to charge down left, the inputs fly in quick succession down-left, down, down-left, down, down-left, down. Sometimes, it just shows down, and down-left doesn’t register until I apply more pressure on the joystick. I play charge characters so I am dropping a lot of charge moves from P1 side because of this.

This is only happening on the left side. I have not changed the joystick out. I did take the balltop off to change my artwork, and the screw holding on the ball top was extremely tight, so I had to work it pretty hard. Other than that I haven’t done anything to it, but I don’t think this was happening before that.

I’m wondering if it’s worth ordering a new joystick. The way I see it, the problem is either the joystick itself, the wired connection, or the motherboard. I haven’t touched the wired connection or the motherboard, though.

Is there anything I can do to debug this issue other than ordering a new joystick?

It sounds like you have a problem with the switch for Left in your joystick.

Access the underside of the top panel and take a look at the switch that is activated when you hold Left on the stick. Try toggling it manually and see if you can reproduce the issue. Double check that the 5-pin harness is connected properly to the joystick PCB.

If the wiring is fine and the switch appears to be the problem you’ll want a new TP-MA PCB assembly for your joystick (you don’t have to replace the whole stick).

You could also replace the switch only, but it is easier to replace the entire assembly.

Dust out the inside of the switches.

Hmm nice. I’d never taken apart the joystick before, but it was nice and easy. My switches were super dirty, and I gave them a good clean and I have not been able to reproduce it. Thank you both :slight_smile: It was driving me crazy.


+1 for cheap fixes. Glad it worked out.

My apologies for necroing this thread from 3 years ago, but I felt it necessary to report that I had the exact same problem. Very frustrating. I’ve tried cleaning out the switches, which all look to be in good working order, but it didn’t seem to fix the problem. I might have to buy a new TP-MA PCB assembly… :frowning:

Has anyone else experienced the left-side inputs of their Qanba Q4 acting up? I love this stick, but if this is a common issue after only a year of use, I can’t say I’d recommend it to others…

Components fail over time–we’ve all experienced stuff like this. Your Qanba Q4 doesn’t have any special voodoo. Swap the TP-MA, or solder on a new microswitch.

I guess I’ll have to… I would expect a piece of hardware to last at least 2 years though, especially considering I don’t use it every day like some players…

+1 for the Altered Beast screen though. B)

Perhaps the microswitch was “made on a Friday before happy hour.” Perhaps you tend to go “beast mode” on 1P block.

Its a local meme/ Running gag we do here at tech talk.
I forgot who actually started it first, but most people would give me the credit since I got it to meme status.