My stick is acting up

im in the process of soldering the wires from the button to he pcb board , and i just wanted to make sure i grounded it right before i soldered anything. so i put the cable on the button and on the ground, the action works on its own without me pressing the button, and when i do press the button the action stops…

any fixes?

If the button registers as pressed when you haven’t pressed the button, you haven’t wired it properly. The circuit is being completed without the button, so your soldering job is probably sloppy. Why it would stop when you press the button is beyond my limited electronics knowledge.

But, I’m not sure I understand what you’re saying completely. What PCB are you hacking? Can you post pictures?

The last 2 controller PCBs I’ve tried to hack have given me problems. I’ve already hacked a dualshock with no problems but now i tried to wire another PCB and there is an issue with lag, when i wire any button there is lag, and it won’t recognize the button press until i let go of the button. In other words it won’t punch until i let go of the punch button. Now, in the case of the directionals it just automatically moves as soon as the ground & the actual button are wired, any thoughts? I haven’t soldered anything yet, i’ve just been testing it.

You don’t write what kind of buttons you use. If you wire “NC” (natural close) instead of “NO” (natural open on the microswitch you should get this behavior,

I got also got a microswitch go bad and it started to behave wierd, kinda like you described, changed it and now im ok

Are you still working with dual shocks? PS1 or PS2? If PS1, what series?

I’m using Happ Competition Push Buttons, i’m working on the PS1 controllers, they look like this

I’m wiring them using Quick Disconnects like this:

All you did was connect the ground wire to everything. You still need to hookup the buttons themselves.

If that controller is anything like a PSX DS1 (and it does look like it), then just follow this.

Have wires connecting the red parts to their corresponding button/microswitch. Either prong should work. I wish I could tell you where your shoulder buttons are, but I haven’t used a PSX digital pad yet.

Edit: Wow please ignore this post. I’m an illiterate idiot =\

yes i know, i took a wire and connected it from the ground to the button with out soldering it

Ah, sorry. Missed that in your first post. My mistake

Edit: I was going through the padhacking thread and found something I thought might be relevant to this thread.

You said that all of the buttons are being rapidly pressed on their own, right? Are you using a converter? Test the pad out on a PS1 game and see what happens.

if i push the button it will not register until i let go of the button

Sounds like the same problem that laurie47 is pointing out in the link. So, are you using a converter or playing a game that uses analog? I’ll keep a look out for anything related to your problem as I go through the padhacking thread.

i am using the usb converter from radio shack i tried it out on street fighter alpha anthology and when i push the button the action wont happen until i let go of the button

When using converters ds pcb is what you should use, tried an all digital psx pad + magicbox psx to xbox converter and it wasen’t playable, ds to xbox works kinda fine for me, seems there’s some lag on diffrent buttons or problems with simultanious pressed buttons.

My new stick will use dedicated pcb’s for every system i use it for to eliminate all these converter problems

I’m not sure if Alpha Anthology has it, but did you make sure to turn off analog in the key config menu? I know 3rd strike has this option.

Make sure the other, non-ground wire going to the microswitches are going to the prong CLOSEST to the ground prong, not the farthest one.

EDIT: I’m still unclear what you mean by “so i put the cable on the button and on the ground”. Please elaborate. Post up a picture of how you’re testing it.

Well i grounded everything by daisy chaining like in this picture:

Then i take a wire and put it on one of the button prongs (there are 3 prongs per button, 1 ground & 2 gold, i put the cable only on one of the gold prongs) then i place the other end of the cable on the correct spot on the PCB board (i scraped the top to reveal the copper) if i put the cable to (x, circle, square, triangle, L1, L2, R1 or R2) the button push does not register until i let go of the button, if i put the cable to one of the directionals on the PCB (up, down, left or right) then the button gets stuck so for example if i put the cable to the Left directional on the PCB then the character will move to the left until i remove the cable from the PCB, once i make contact again then the character moves again until i remove the cable and if i puch the button the character stops (so it’s reversed i guess, a button push actually stops the action but only on the directionals, like i said before on the other buttons the action registers after i let go of the button). Just to be clear, i do not solder the cable i just place it on the correct spot manually. Hope someone can help

Let’s try this another way:

I can see clearly now the raaain is goone!!

Yes, that seems right on the button. (no pun intended) Toodles, is right, gotta avoid the NC prong or else you’ll have a weird stick, unique but…weird. Looks like it will be a clean install once you get it all wired up though, and Im a fan of clean installations.

That is exactly what it was, thank you guys so much. I really appreciate all the help i received. I was able to complete everything in a snap after that.