Madcatz Xbone fightstick for PC issues

Has anyone found the solution yet to the Mad Catz® Arcade FightStick™ Tournament Edition 2 for Xbox One™ triggers problem? Incase you don’t know, the problem is that the Trigger buttons RT and LT completely don’t work and the bumper buttons RB and LB are reversed. I’ve had talks with both Microsoft and Madcatz, microsoft stating they don’t support madcatz, im assuming they mean their drivers don’t and madcatz has no solution yet, anyone any luck with it?
Ultra streetfighter just came out for Steam and would really like to use my fightstick for it… but not with half the buttons working.

Best solution right now is triple mod it with the TE2 crossbone & ps360+. Basically you’ll be using ps360+ to play on PC.

Gonna cost you about $100 more, but it’ll resolve your issue!

The ps360+ might be overkill for his problem when a zero delay PCB would handle the pc side just fine. Or you could learn to play with 6 buttons and “fix” the bumpers by remapping the in the game

Well he said TE2, so I’m assuming he’s talking about the new fightstick from Madcatz. Afaik, there’s no madcatz TE2 driver for PC yet.

And yes a zero delay pcb will work, that is if he’s comfortable enough to find out where to tap in to the pcb vs using the crossbone + ps360+ where everything’s already laid out for you

As of right now, my options are hopefully get a refund on the stick and buy one that actually works for my PC, or wait until MS makes drivers for the damn thing to work with PC.

The zd (at least the ps2/ps3/pc model, don’t know about the pc only version) isn’t common ground, won’t work for a dual mod.

the ZD isn’t common ground? didn’t know that.

The PS2 ZD Encoders I’ve used were common ground and I did an Agetec dual mod with them.

Hmm, I probed around on one without going over every single point and concluded it was, yet was unable to get one to work (tried the box on ps2, not pc or ps3) with a project box setup after retrying twice (soldered directly to the board the first time, snipped the qd’s and soldered from the signal wires and one ground line the second). Probed around more thoroughly with my multimeter set to 2000 ohms and was unable to get continuity between a few points, which coupled with my inability to get the thing working in a project box, led me to believe it isn’t. I pulled one back out after reading your response, discovering that I was able to get a reading across all points by setting the multimeter to 20k ohms, though some connections are reading 5.58 ohms or 11.17 rather than the 0.01 I get when I probe two points in the same “grounding group” (like an open ground box versus a ground point in a cluster like K4-R1). So while I apparently fucked up by setting the multimeter to 2000 ohms while checking ground points, I still don’t know what the problem was with the project box. I could get the thing to read the start input briefly upon plugging it into a ps2, then it would do nothing- both times. The control harness was fine (as it works with the other 4 project box pcb’s I’ve done), and the ZD works fine by hooking it back up normally, so I guess I’m stumped. Any idea what might have went wrong? Since I undid the whole thing, I don’t have pictures at this point. I checked the ground connection between the DB25 and the ZD both times, and this wasn’t a dual mod project box, so there was no VCC connection involved.

Yeah I have a crossbone/ps360+ connection using the drivers on and I gave my ps360+ priority and hold home to get xbone. You can’t use major nelson’s drivers for the TE2, huh?

Can’t you utilize the 3rd party drivers that the one hobbyist released to get around that, or no? I never installed them but might since I can’t get the major nelson linked ones to work for my system for some odd reason.

I’m really sorry - I have no idea what to suggest. All I can say is that it worked when testing it dual modded to an Agetec pcb.

Unless there’s a different revision of the PS2 ZD Encoder floating around somewhere…

Hearing that you were able to get it to work in a dual mod was helpful in and of itself. I’ll give it another shot just to see how hard I should kick myself for spending more money (not to mention effort) than I had planned on my arcade control panel.