MadCatz TE/SE Problem: Buttons work, Stick doesn't

Problem: You have a MadCatz SE or TE stick, all of a sudden for no reason, on the console, the buttons work but the stick doesn’t. Everything works fine on the PC.

Solution: You moved the slider switch that’s labelled ‘LS-DP-RS’. Move it so the slider is in the middle, on the ‘DP’ setting.

The slider switch controls whether the stick movement is the same as moving the Left Analog Stick, the Directional Pad, or the Right Analog Stick. Most games, and the PS3/Xbox dashboard, will ignore movement on the Right Analog Stick, so it will look like the stick isn’t working if it is set to ‘RS’. For all fighting games and the PS3/Xbox dashboard, the ‘DP’ setting works best.

Mods, please sticky, hopefully it will cut down on some of these posts that pop up every other day.

Hugs ‘n’ Kisses,

I just realized I typed out Dragon Punch for DP…go me.

Toodles, I have this issue on my SE stick for the PS3 and its not because of that switch. I have already checked that. Infact, it goes in all directions except down. It was working fine, until I replaced the stick with a JFL. Do you know what I should do to fix it?

Heh, did it go ‘all directions but down’ or did it go 'one direction, and one of the diagonals of the same direction '? Former, you’d have to check the microswitch board with a multimeter to see if one of the switches died. If the latter, the five pin connector was put in upside-down. (I need to verify which directions this actually causes, so I may be off. The only hard-fast rule is ‘only one cardinal direction works’)

But if the stick hasn’t ever been openend, the first post if the answer 90% of the time.

I support this for a sticky.

Just goes to show that common sense really isn’t so common.

I’ve had the “one direction doesn’t work” shenanigans after replacing the stick with a JLF also. It’s the wiring harness slowly sliding off. The SE wiring harness is ass and doesn’t clip on so you have to glue it down or it can slip off every once in a while.

To any one who can offer some sound advice,

Was wondering if you guys could give me some advice about this very same problem. I noticed that when i plugged in my SE to my PS3 all buttons were operational but for some odd reason my joystick would only register moving to the left. Not only that, but if i tapped once going left, for some reason it would register as a “constant” and would keep going left with out allowing me to press any direction. I verified my Left/Right/Direction indicator was on the “D-pad” setting, but still no fix.

I opened it up and did an inspection of the 5-pin wiring harness. I took notice that there was a small “pinch” in the ground wire, but nothing that seemed to penetrate through the plastic coating. I inspected the joystick PCB for any cuts, scraps or scratches. No findings.

Now i don’t have a multimeter but the only other thing i can think of is maybe my micro switches went dead on me. Inspected those to see if i still heard a solid click and it seemed fine. I decided since it would be difficult for me to narrow down the problem any further, the best course of action would be to replace the micro switches and solder each micro switch directly to the PCB 5 pin harness. I have spare micro switches from a May Flash mod i did recently. My question is this: On the MadCatz SE PCB is there a specific layout as to which pin indicates which direction/ground. Here is a picture for reference.

Or better yet, could i bypass the 5 pin route and solder each micro switch to a soldering point on the PCB? Any advice or comments would be greatly appreciated.

disregard last post. unscrewed the PCB and behind it are the solder points clearly labeled. Going to solder the micro switches to the PCB and see if that works. Will update with my progress.

I’m having a similar problem with my SE XBox 360, except every time I push the stick up it disconnects the controller. The green button starts to flash and I get a pop up asking me to reconnect the controller. Has anyone else experienced this issue?

so quick update, I re-soldered all micro switches to the respective points on the PCB and i still get the “constant” up. Not really sure where else to go from here. I ensured the soldering points did not touch or bridge, as I’ve read that could cause this sort of problem. Tried several ways of connecting each micro switch ground to the PCB. I first soldered an individual wire to each micro switch, twisted them together at the end, then used another wire to solder both ends, one side to the 4 twisted pair and the other to the GND point on the PCB. No dice with this method. Tried daisy chaining a wire from the GND point to each ground end of the micro switches and still get the same result: constant up input on the joystick. At this point i really don’t know what else i can do. I’m open to any suggestion, tip or technique to solve this problem. If any one needs me to post any additional pics of what I’ve done just let me know, at this point I’m stumped. :wtf:

Take a picture of soldering job on the micro switches. Chances are you might have a signal wire attached to the wrong terminal on one of the switches, causing it to constantly register as activated.

Ok, so here is the back side of the PS3 MadCatz SE PCB.

Top view of the soldering points. Not the best soldering job in the world but all points are jointed.

Side view of the soldering points. I ensured none of the points touched or created a bridge.

and here are the micro daisy chained micro switches. the colored wires represent a direction while the black wires represent the ground.

The ground for each switch is soldered to the sort end blade on each one. Also i have the the ground wire daisy chain leading back to the ground point. At first i did not have it like that, rather the chain simply ended at the last micro switch. In an attempt to see if my electrical flow was bad i chained the last switch back to the grounding point. Both attempts lead to the same result, constant up.

just a thought that hit me today, would it be possible that the PCB itself is faulty? That is presuming all my solder points are correct.

You might not be getting much help with your problem as it’s rather off topic to the original post. IE, a specific setting problem a lot of people have, not a wiring/PCB problem.

It’s not “the very same problem” as you first stated.

ahh, noted. That’s my bad then. Where would this information be most appropriate? I did a search the first time and this was the closest thing i could find. should i start up a new thread?

I don’t think there is any harm in making a new thread for that. You have a pretty specific problem and have done a bunch of legwork, so I don’t see why not.

Best of luck!