MadCatz TE round 2 ps3 directions not working

Hey guys,
back in july I bought my first arcade stick, a madcatz te round 2, second hand.
When I got home it turned out that the only directions that worked were down and down-back.
I checked the stick to see if it was damaged and it didn’t look like it was but I decided to order a new sanwa JLF anyway.
I replaced the stick and the problem persists. I have also chanched the cable that connects the stick with a new one but still no dice.
Does anyone have a clue as to what the problem might be?
Thanks in advance.

Sorry if this kind of question has been asked already, I didn’t find it and I just want to fix this problem ASAP.

Sounds like a bad PCB. Do you have anything else you can test the JLF with?

I don’t really. I feared it would be the pcb. Well time to get a chimp I guess. Thanks for answering so quickly man.

Try flipping the 5 pin harness.

sounds exactly like that, Sanwa JLF 5 pin connector upside down :slight_smile:

Soooo… flipping the harness solved the problem. :expressionless:
I feel really stupid now.
Thanks for the help guys, I would’ve ended up spending a lot more money without your help.