Madcatz TE fightstick "please reconnect controller" error

Hey everyone, I’ve recently been having a problem with my TE fightstick for xbox 360. When I play sf4 once in a while i will get a notification on the screen saying that i need to reconnect the controller and then will be ok a second after the error has occurred. When I play online my character just stands there (obviously) and while playing arcade mode or local vs the game will pause. It is quite annoying especially when we are playing local vs matches. I have checked the breakaway cable and actually swapped them with another TE’s stick (one that works well) but the same problem occurs on my stick. Ive tried several different methods before starting the system and game up but I get the same problem.

I have tried to…

[*]Plug in the controller normally

[*]Unplug the breakaway cable and then reconnect before pluggin in the controller

[*]Unplug the breakaway cable while the USB connection is plugged into the xbox 360

[*]After a successful night of playing I would leave the controller plugged in and would play the next day, leaving everything as it was the previous time I played.

I haven’t found a solution on the internet or found people having the same problem unless they have dual modded their stick. I have not tried to dual mod the stick, the only type of modding that I have done was change 6 buttons to a different color. The problems has been happening for about a week now. I would play everyday hoping that somehow it would want to fix it’s self or find a pattern of how frequently this error occurs. So far the error occurs everyday and about an average of 3-4 times within a 4 hour time span. Today I played for a good amount of time but only encountered the error once.

If anyone can help me, suggest an alternative, or possibly talk about having similar problems hit me up…

Thanks alot,

BTW, I have a round 2 TE stick… also if there is a similar post somewhere on this forum I apologize in advance.

It’s most likely a PCB problem.

I’ve dealt with this problem and it took me about 7 or 8 months to solve, but unlike you, I dual modded mine. If you’ve never modded yours there really isn’t any other explanation other than the PCB being bad, or the soldering from the usb cord was done poorly by madcatz.

The two TE pcbs I had would give the same error you mention and also have trigger issues (I did as much research as I could into it, and there are quite a few people who also have these issues without dual modding). The trigger issues went away when I used the fightpad, but the disconnect error still happened every once in a while. I completely fixed it by using thicker wire on the power points to correct some cold joints I had.

Anyways, I don’t want to get too irrelevant. From my experience, I think the best solution for you is to contact madcatz and try to get a replacement and hope you get something that isn’t borked. I got two pcb replacements from madcatz in which the first one had the same issues, and the second one wouldn’t even power up.

I fixed my problems by replacing the pcb with a fight pad pcb because I was fed up with the TE pcbs.

Thanks for your time and feedback. It is greatly appreciated.

this has been happening to me too and i have never modded my stick. also its only a month old. btw what is a pcbs lol. how ever my stick seemed to come used and the down foward seems not responsive… gonna call them and get a replacement before the warrenty is up. ps it only takes the smallest movement of the wire to get the disconnect to happen and if i even push the usb in tighter it will happen everytime. sucks too because i was just starting to get used to the stick …

some one just told me that you could possibly use the usb end of a wired controller. will this have compatibility issues, like imput lag or anything ???

Are you talking about the breakaway cable? Because I have switched the breakaway cable from another TE stick and that did not help my problem. The weird thing is that the controller for the most part works. There are just some instances were it will lose its connection.

Are you talking about the breakaway cable? Because I have switched the breakaway cable from another TE stick and that did not help my problem. The weird thing is that the controller for the most part works. There are just some instances were it will lose its connection.

i just switched my usb end of the breakaway from my 360 controller and it fits way better and i am able to wiggle the hell out of it and it no longer disconnects.seems to me the te usb is too small.
hope this helps…

I had the same problem with the SE stick, so I bought a Sanwa in december and the problem disappeared until tonight. Can this PCB problem happen with Sanwa sticks too?

sorry to bring this thread from the grave. I have this error appearing on my Round2 stick and it really puts a damper on playing online/offline with friends. Is this a PCB problem and is it a easy fix. Thanks for any help.

I had a wired xbox controller that was doing this to me I got a new USB cable from newegg cut out the old one and soldered the new one in it worked fine after that.

I got this problem in conjunction with the non-responsive RT/LT buttons issue. I solved it by grounding the top and bottom metal plates to the JLF ground. But if you’re in-warranty just contact MadCatz, it’s not a unknown problem.

Sorry about the necro, but can u help me?
I also dual modded mine (actually another guy did for me) and my xbox part of the TE simply died for good. I can still use it normally to play on PS3/PC so it’s not a USB problem.
What exactly you did to fix the TE?

Before Jumping to the PCB, perhaps its the USB cord thats damaged.

Take it back to the person who dual-mod it maybe they could fix it.

Problem is, the person that dual modded it, did at one booth at EVO (was the guy that was right next to madcatz booth.
And I live in Brazil, so it’ll be kinda hard to contact him…

It’s for sure not the USB cable, because the stick works fine on PS3 and PC

It could be the USB connection for the Xbox 360 PCB.
All it takes is a Data - or Data + line going to the Xbox 360 PCB to loosen up.

If you can open up your stick and start taking photos and post there here, I am sure someone could spot something.

I opened it and there were no loose wires, all of them seem to be connected.
Can you hint for something that I should look for, so I can reduce the number of photos taken? Don’t wana waste your time posting useless stuff.

AFAIK, I found 3 PCBs on my TE, not including the Chimp.

It goes like this: Buttons -> PCB1 -> PCB2 <-> Chimp ->PCB3

If i’m not mistaken, the PCB1 is just to map the regular buttons+stick, so if it was this the deffective one, the buttons wouldn’t work for PS3 as well.
The PCB3 is just bellow the USB wire compartment, and it seems to just map the turbo buttons Home/Guide. Again, I don’t think that this is the problem.

Finally, PCB2 is directly connected to the Chimp board, and to the USB wire. It’s the one that’s probably deffective.

What you are talking about is that maybe this PCB didn’t die, but rather got some wire loose right?

Sounds like it just a ChImp and 360 PCB.

> What you are talking about is that maybe this PCB didn’t die, but rather got some wire loose right?

If there is a short circuit (when the wrong wires touch each other), then the stick will disconnect from the Xbox. This can happen if wires are loose, if the USB cable is worn out, if there’s a solder bridge, or if there’s a problem with the printed circuit board.

Okay, i’m opening my fightstick again tomorrow and gonna take some photos.
Thank you all for all the help so far :slight_smile: