MadCatz SE Fightstick: Execution Rate

So it took me a while to actually realize this, and it was brought to my attention by my brother who used my SE Fightstick one day.

I was letting him play one day against the CPU since it was his first time playing. He pointed out that he sees the CPU put out faster jabs/shorts than he was able to execute himself.

We took his theory into Training Mode and tried many different things to replicate the rate at which the CPU can execute jabs/shorts. The only way were were able to do this was to use the turbo feature on the Fightstick. I know how to button mash, I know how to double tap, and that whole lot.

From my experience, its seems that this small feat is impossible simply because of the buttons. It really feels that I can tap the button just as fast as what is possible by the CPU, but what actually comes out is totally different.

Anyone else have any other experiences with this? I’m really curious to find out if this is because of the actual physical design of the button. Or is it the electronics in which it operates and registers a depress.

But you can go as fast as the cpu with the normal 360/ps3 pad?

Never tried with a pad. That is the least of my concern.

Well if the pad is the same speed as the SE then something else is up

ai of course is going to pull perfect combos every time. It’s not so much button mashing as proper link timing, which isn’t something you can just look at a value for, it’s something you have to feel out.

Linking isn’t the issue. I can link. But the fact remains that I know for a fact that I can press the SE Fightstick buttons faster than what is being registered. Is this just an issue with the stock buttons? Can anyone else confirm/deny? I ordered Sanwa parts and I’m wondering if they may have the same issue.

Sanwa buttons are the best buttons out there, so if you find they have that issue too, it’s one you need to learn to deal with.

dude im going crazy waiting for lizardlick to ship my buttons. its is the sock buttons they are terrible sometimes while im focusing it lets go without me intending it to. the buttons respond half the time i swear

Aside from my original post, I’ve had many instances where I press a button at an angle and it gets stuck. Thats just silly. Hell, I’ve even had times where I’m trying to mash out a throw and it does nothing but eat an ultra. And on top of that, sometimes I get a random tech recovery when I don’t even press buttons. Its a Fightstick from hell I tell you!!!