Madcatz fightstick TE street IV, joystick not responding.

Hello SKR members,

I need your help figuring out what possibly went wrong with my fightstick.

I was replacing the stock Sanwa actuator with an oversized. I removed the 5 pin connector from the joystick and all the connections on the buttons so I could remove the cover where the joystick is attached to. after I was done replacing the actuator, I connected everything back together. before screwing on the bolts on the cover, I made sure that all the buttons worked and joystick. Unfortunately, the joystick didn’t. I lifted the cover and made sure the 5 pin connector was attached correctly, which it was, but I still wasn’t getting a response from the joystick. Again I took off the cover, but this time flipped the 5 pin connector, but still no luck. The 5 pin connector on the PCB is firmly attached and hasn’t been removed.

I thought it might be the brook converter (Xbox 360 to Xbox 1) but I tested it with a different converter, but still no luck.

Could it be the PCB has gone bad?

Any suggestions would be greatly appreciated.

These early Mad Catz TE sticks (both PS3 and Xbox 360) have poorly made PCBs which all known to have issues.

I also take a multimeter to the USB cable and test to see if the USB cable have no breaks or shorts.

@Darksakul Thanks for your input. My friend has the same fightstick and I swapped over some of the parts, and I was able to determine that it is the PCB that has failed.

I’ll be ordering the Brook UFB real soon.