Logitech driving force gt using brook converter ps3-PS4

I’ve just purchased the ps3-PS4 Brook converter to use my Logitech driving force gt wheel.
I have done the firmware update (there is only 1 update to choose from)
And none of the buttons work, the accelerator and brake Work and that is it! Any ideas from anyone?

Is this the one you’re referring to? If so, that’s exactly what I use. There is more than one firmware, I had to download the (For SteeringWheel)PS3 to PS4 from https://www.brookaccessory.com/download/PS4/

Hope that helps and isn’t something you’ve already tried.

1 Like

Thanks for the reply, yes, exactly that! Everything I’m reading states there’s more than One update, however there is only One update to chose from,
Ive followed the instructions to the letter and extracted every file, then “run as admin“ but nothing.
I’ll try it on another laptop but it so frustrating.

Thanks for the reply.


Go to download

Go to PS4

There should be

  • PS3 to PS4
  • (Tournament)PS3 to PS4
  • (For Steering Wheel) PS3 to PS4 --> this is the one I used.
1 Like

Me again,
I have solved the issue! It wasn’t the brook converter, I do apologies…I took the steering wheel apart and looked over the circuit board with a magnifying glass and I had a dry solder (I believe it’s called) so a drop of new solder and boom…all is working :+1::+1:

Many thanks again

1 Like