Imp v2 + MC Cthulhu + RJ-45: Doesn't work on PSX or Gamecube

I’ve been kicking this issue around in Toodles’ Imp thread for month now, but since I can’t exactly pinpoint where it’s happening, I might as well spin it off into it’s own thread.

About a month ago, I got a Imp v2 to put in my stick. Previously, it was a dual mod with a MC Cthulhu (hardware v1.3, firmware v2.2) and a Madcatz 4716 PCB, with a v1 Imp to switch between the boards. I had cables for USB (to use it on 360, PS3 and Xbox 1 with a USB-to-XB cable), PSX (to play on a PS2 and on Dreamcast via converter) and Gamecube, all of them working with the Imp v1 set up. When I got the Imp v2, I got rid of the old Imp and followed Toodles’ instructions on using it with an MC Cthulhu.

Since modding it in, the stick works perfectly fine on 360 (which confirms the Imp’s switching is working), PS3 and Xbox - I can plug it into those systems and play games with the stick just fine. However, my PSX and GC cables do not work - I will plug those cables into my stick and into their respective systems, but the systems do not see a controller connected.

The wiring on the stick is as follows:

  • The G-V columns on the Imp are connected to the G-V holes on row 1 of the MC Cthulhu
  • The VCC hole on the Imp has a wire that runs to the VCC screw terminal on the Cthulhu
  • The RJ45-VCC hole has a wire that runs to the V column hole on row 3 of the Cthulhu
    (I would post pics but my phone’s camera is crap and I don’t have access to a decent quality camera)

In the Imp thread, Toodles suggested I check the continuity of the wires running from G-V on the Imp and Cthulhu, except for the D and E columns. I’ve done that, and the wires check out as being connected. I’ve even completely re-solded the wires between those columns after the USB consoles started having problems, and while it fixed their issues, PSX and GC functionality still don’t work.

Is this an Imp or an MC Cthulhu problem? Is there anything else I can test on the stick to figure this problem out?

can it be a RJ45 Jack problem? i mean… you know that pin 1, 5 6 and 8 are working well (mapped well) try to test if 2 3 4 and 7 are mapped correctly

Just tested it. There’s continuity between those pins and the A,B,C and F columns, so it can’t be that.

Bumping back up. Still haven’t figured out this issue.

Update your firmware. :stuck_out_tongue:


Yuppy probably nailed it!

Don’t expect your MC Cthulu to ship with the latest firmware installed. They generally don’t. (Haven’t for me when I opened mine…)
If you have a PC available or access to one, the firmware update is very simple… Follow the directions included with the Firmware revision download.

I had problems with my first MC Cthulu with the original firmware. Just didn’t behave well with the PS2. There was a workaround for the trouble (boot up with a regular PS2 joypad or PS2-native joystick, then plug in the MC Cthulu-d joystick). A later revision took care of that. Updated my first MC Cthulu 2 times so far to deal with big issues and add console support. The second MC Cthulu board I own has also been flashed once already, too.

You can get the latest firmware in the first thread of Toodles thread about the MC Cthulu. Should be the thread with “Dreamcast flavor added!” or something like that in the subject.

The Dreamcast is the latest retro system to have support added for it through the MC Cthulu. You can expect to have to flash the MC Cthulu firmware with new updates as bugs are worked out and support gets added for more systems.

Marvelous piece of hardware!

See, but I already have the latest version of the MC Cthulhu firmware on my board - if I didn’t, switching to the 360 mode wouldn’t work.

Are you sure you wired the cables correctly? The wires that are pinched into the Cat5 connector has to be in the correct pins.

They worked with my Imp v1 setup and I followed rtdzign’s thread when making the cables, so I know they’re wired in the right places.

Can you post some pics of the wiring of the imp2 and mccthulhu?

Ouch… Sorry about the firmware. Again, probably a hardware issue then. I subscribe to the KISS principle and have never done a dual mod for 360. Hard enough keeping track for one system or PCB board!

NC, are you sure you won’t be going to a tournament in the near future? There are guys here who make the rounds who have done several dozen mods between them. They might be able to fix the situation for you for a price if you’re in the area at a future tourney. Don’t know that I can say anything else useful.

Good luck with it!

Gut reaction says it could be a fault with your RJ45 cables and/or jack.

Check for continuity between the IMPv2 > RJ45 jack. If passing the test then check for continuity between each end of the PSX cable. If passing, plug the PSX cable into the jack and finally test for continuity between the IMPv2 and the end of the PSX plug.

Aside from that I don’t know what to suggest.

Well, my roommate returned this weekend with his good camera, so I was able to get some pics of my (admittedly crappy) soldering job as well as do some additional connectivity tests.

I checked the following things:

  • Connectivity between the Imp2 and the MC Cthulhu’s G-V holes. They all check out as connected.
  • The USB and Gamecube RJ-45 cables, making sure any wires haven’t broken. Everything checks out as working there.
  • Connectivity between the Imp’s G-V holes and the RJ-45 jack. Seems to fine there
  • Connectivity between the MC Cthulhu and the ends of the cords when they’re plugged in to the Imp’s RJ-45 jack. Of course, USB checks out fine - when I have that plugged in, the respective Cthulhu columns are mapped to the correct pins of the cord. When plugging in the Gamecube cord is where things go awry.

According to rtdzign’s thread, V should map to pin 1 on the GC cord, F to pin 2 and G to pin 3. However, when I plug in the GC cord, there is no connectivity to any column on pins 1 and 2, and both V and F(!) have been mapped to pin 3. Since I’ve checked that the Gamecube cord itself is properly put together and working (it worked with my Imp v1 setup), I can only assume that this is an issue with the Imp. I can check with a PSX cord if you guys would like - it just seemed easier to do with the GC cord since there’s only 3 pins to check.

Finally, some pictures of my soldering job:

Wow your Cthulhu is a 1.3 Cthulhu… Help Toodles ;_;

Finally got off my lazy ass and tested my PSX cable with the assembly. Per the PSX cable installation instructions, the lines should look like this:

PSX pin    MCC Column
1          C
2          B
4          G
5          V
6          D
7          A
9          F

However, with the PSX cord plugged in, I get these results with a multimeter:

PSX pin    MCC Columns
1          C, G
2          B, G
4          G, A, B, C, D, E, F
5          NC
6          D
7          A, G
9          NC

No signal from pins 5 or 9, and only pin 6 is sending the correct signal. Still stumped as to what’s causing this issue.

Those results aren’t possible; I dont think you’re using your multimeter to check for continuity properly.

Okay, I admit I fucked up and set the multimeter to the diode setting instead of 200 ohms, which was causing all those multiconnected readings. Otherwise, my multimeter was set up just like in that link.

Anyway, with the 200 ohm setting, the PSX cable is connected to all correct pins except pins 5 (V), 6 (D) and 9 (F). Gamecube doesn’t have connectivity on pins 1 and 2 (V and F). That V and (in PSX’s case) D are not working on those cables while it works just fine when I use USB stumps me.

So… no new advice?

Nothing I can do then?

? You know that some of the pins aren’t connected. You even know which pins aren’t connected. You know how to check for continuity with your meter now. Youve got a console cord, a neutrik, an internal rj-45 cord, the RJ-45 jack on the Imp, and the connections from the Imp to the Cthulhu. (With the exception of the D and E columns) it’s a straight shot from the end of the PSX cord to the Cthulhu. Somewhere through that very direct chain is a break; find it and fix it, or talk to a tech willing to troubleshoot it for you.