HRAP 2 problem

Hey guys,

I purchased my Hrap 2 about a month ago and now it’s starting to act up. The Triangle button on the stick isn’t working properly. I thought it was the button configuration, but when I went to the button configuration screen (I was playing Guilty Gear XX Slash) and I tried pressing triangle, but it would just flash and wouldn’t work.

After that, I opened up the joystick and removed the QD and then reconnected it, but it still wouldn’t work?

Any help would be greatly appreciated.



Touch the two QDs together and see if that works.

This might seem stupid, but do you want me to touch both of the QD with bare hands or something, or do you want me to touch the two QD’s and then reconnect them?

BTW, thank you very much Taiki.

lol. He means to take one QD in one hand, take the other QD in the other hand, and touch the tips of the QDs together while in a game that recognizes that button.

I tried touching the two together, but the button (which is triangle) flashed once and then disappears. Then I tried something differently, I touched the two QDs and then before the button disappeared, I touched the two again and it worked, but when I put the reconnected the qd’s again, I got the same problem.

Any ideas?

Get a custom stick or put in a better PCB (PS1 etc.). Other than that…dunno. I dont like HRAPs. They work but too many issues after you buy them. I want my stick to only have problems when I do something wrong. Like spill Red Bull all over them.


I wouldn’t have gone for the hrap if I had the money to buy a custom at that time. Now that I have the money, My HRAP starts acting weird, sigh

Yeah, I thought it’d last at least a year or so. I have a T5 stick and the strange thing is that, the T5 stick is still working good. No problems with that.

Any other ideas?

It sounds as though you might have a short in the wire, ie the wire might be broken somewhere inside the insulation. Do what you did before, open it up, and touch the QD’s together. See if you can find a position that you hold the wires where touching them together gives you normal behavior. If so, then try to rule out which wire is bad and replace it.

I sorta had a similar problem when I was trying to play AE and Alpha Anthology. My stick would work but none of my buttons would produce a move. I changed the default button settings in the config menu so that every button is only ONE BUTTON, meaning I’m not setting the triangle button to :3p: or :3k: or any variation of the two. I removed my last two button on my HRAP and put button fillers in there to make it like a cabinet but I still had :3k: and :3p: set for the nonexistant buttons. When I didn’t assign anything to the nonexistant buttons, them my stick worked fine.

Like I said though, it sounds similar but I don’t know if that’s your problem.

Yeah, I think that’s the problem, but I tried doing that and I couldn’t find the spot where the button works.

How about if I try using a multimeter to check which one is bad or something. Will that work?

Damn, I’m really frustrated.

Maybe look at the wires, PCB, etc and see if there’s any visible damage. I know my friend’s R1 is iffy because there’s a small laceration on one of the wires hooked up to R1.

The pcb is the under the turbo section, right?

BTW, I think I have really decided to use a Dualshock PCB to replace the stock one.

I don’t think I’d be able to put the dual shock pcb under the turbo section, lol.

Is there a guide for that?

a guide to wire up a psx ds1? yea look under the pad hacking thread

Where is the pcb for the HRAP 2, because I can’t seem to find it.

The PCB is actually further in the HRAP2. If you look at the turboswitches, there should be a second set of wires going out. Just follow those wires and you’ll find the Hori PCB.

With the bottom plate off, looking underneath, you’ll see where the PSX cable plugs into the PCB, and the chip on the PCB. You’ll see two screws holding the plastic piece with the turbo switches. Remove those two screws, and lift the turbo piece up from the top; the PCB is attached. Once its remove, BE CAREFUL when separating the PCB from the plastic turbo piece; there isn’t really anything holding the slider switches in, and if you fumble it you’ll never find all of the switches again.

If you’re problem is just that one button, Im telling you now that replacing the entire PCB just isn’t worth the trouble. Even if the problem is with the wires, it’d be much easier to fix that problem than redo the whole damn thing.

First, figure out which of the two wires is the ground wire. Use a multimeter, and figure out which one is connected to the black wire coming from the sanwa harnes. Mark that wire with a sharpie.

Next, figure out which one of the wires on a nearby button is ground. Pick a button near the problem one. We’ll call this other working button the test button. Use the multimeter, and figure out which is the two wires for that test button are ground. Mark it with a sharpie.

Now, figure out if the problem connection on your bad button is the data wire, or the ground wire. With the stick plugged in in a training mode for some game, touch the ground wire of the bad button to the data wire of the test button. If this works every time to try, we can be pretty sure the ground wire on your bad button is good. Next, touch the data wire of the bad button to the ground wire of the test button. If this works every time you try, we can be pretty sure the data wire of your bad button is good. Lastly, plug in both of the wires from the test button into the physical bad button. Press the button a bunch. If that works, we can be pretty sure the actually button microswitch is good.

Congratz, you just tested both of the wires and the physical button.

If the button looks to be the problem, plug both of the bad button wires into that test switch, and press it a bunch. If it works fine, then you can be certain the problem is the button. Buy a new sanwa button to match, and replace it.

If the ground wire appears to be the problem, look to see if the QD on the end is coming loose. If so, replace the QD and repeat the tests. If the wire works sometimes, and moving the wire fixes or breaks the problem, its a bad wire. Run a piece of wire from the test ground wire long enough to plug it into both buttons; or try to remove the replace the length of wire at the pcb (much messier because of the hot glue). Problem solved.

If its the data wire, look to see if the QD on the end is coming loose. If so, replace the QD and repeat the tests. If the wire works sometimes, and moving the wire fixes or breaks the problem, its a bad wire. Bad wire would mean you have to either cut the wire close tot he PCB and connect a new length of wire, or desolder and replace the wire at the PCB (messy cause of the hot glue).

Thanks to you, I found the bad wire! Actually, it wasn’t the ground wire that was causing the trouble, it was the damn data wire.

Now that that’s outa the way, how do I know what’s wrong with the wire. I tried finding a spot where it could work, but no luck. Then I checked to see if the Qd was loose, but it wasn’t.

So this means that I might have to check the PCB to see if the wire is the problem.

BTW, where could I get a replacement for a QD? Radio Shack?

Thanks a bunch,


Yeah you can get them at Radioshack. They kind of a rip though, like at most 8 male for $2. You can get 100 on Ebay for like $5 but you probably don’t need that many so Radioshack is good for a quick fix.

So, the QD that I replace is unusable, or can I just take it off and put it back on and it’ll work?

If you pull it off, there should be bare wire exposed. Touch that to one of the grounds. If that works, ya, replace the QD or try recrimping that one onto the wire. If it doesnt work, there’s something wrong with the wire itself, not the QD.
Check to see if there is any damage or anything weird where it is soldered to the board. You can try cutting the wire about 1" from the board, stripping the end, and adding a new wire to it either by soldering or the old ‘twist tight and wrap in electrical tape’ method. If the break in the wire was in the part you cut off, problem solved. If not, the problem is likely where it solders to the board, and you’ll have to desolder and replace it.