How to install the Madcatz TE2+ driver - says it is unsigned

I am trying to install the TE2+ driver found at for Win 7 x64.

During installation it says the driver is unsigned. I allow it to install anyway. In device manager it is flagged as not working properly, saying Windows detects it as unsigned. The icon to switch randomly appear in my tray but clicking it provides no dialog. (I uninstalled the driver and and software and it is still there… anyone know where it is located or the proper uninstall procedure? I uninstalled from device manager.)

The stick is detected by windows and works fine (but not in SFV) in PS3 mode.

How do I install this driver?

The specific file I installed was called Fight_Stick_TE2plus_PS4_7_0_54_5_x64_Full.exe.

There are two files to download and install

I am nto seing them. Can you please provide a link?

If you go to and select Win 7 x64 as OS, then Select TE2+ as product, then click download your driver it only gives me a zip with the file above in it (and install instructions).

Any help from anyone who has knowledge of this issue would be appreciated.

someone mentioned somewhere here that you have to switch it to x-input in the system tray… Not sure if that will help you but only info I can find at the moment.

Thanks for the idea, but the tray icon does not appear. It does strangely appear (but does nothing and responds to neither right or left clicks) AFTER the flagged driver is uninstalled in device manager, which it shouldn’t. Device manager no longer recognizes the stick at this point because the driver has been uninstalled.

Found out the software controlling the driver icon in the tray is in program files/mad catz. There is something that causes the tray software not to be used when the driver is installed but has unsigned/has an error, but when the driver is uinnstalled it tries to load the software. I speculate that some start up event checks to see if the the driver has an error (and so doesn’t run) but doesn’t bother to check to see if the driver is actually installed, since the software shouldn’t be there if it were installed. Some bad programing assumptions going on over at Mad Catz.

Has anyone had issues with it being unsigned at all? I have tried installing it after disabling signing checking but it still gives me an error in device manager.

No issues here. Ordered from amazon. Ran installer, plugged it in during install like it asked and no issues since. Icon shows up to switch between dinput and xinput. Running windows 10 x64. I didn’t even see anything about the driver not being signed. I will try it on a win7 x64 machine and let you know.

Ran the install as admin? Tried creating a test windows profile and logging in and testing there? Have you tried this on a different machine yourself?

Thanks for the reply. I have not tested on a different machine, but I will try so later today. I did run as an admin.