How come sometimes Godweapon shows 0 users connected?

When there are like 20 games going on?

I try to join or create, and I can’t see my own name in the game room. I can’t chat in channel either.

It seems like it is working fine for everyone else . . . except me.

There is something on it here:

rofl, is it normal to be banned from a site you’ve never been on before

it would be pretty rad if you copypasted because i can’t see that shit for some reason and i’m never able to get on GW these days because of that connection problem!

I tried the Supraclient thing. Worked for me.

I find that supraclient doesn’t work properly with slower connections.

Quick Fix:
Download and run TCP Optimizer:

Long version:

A problem exists in the original server and both TRAC’s decompiled server and EmuLinker. When the server is full, that is many people logged in, and many games started, some people have trouble logging in. You seem to get half logged in, but can’t chat or see any chatting or start a game, etc. It also occurs more often if the server owner has multiple long MOTD messages.

I suspect this is caused because the Kaillera protocol sends the current state of the server, including all user names, and all games, in one big message. It also groups messages in packets of 3, so MOTD lines could be included in the packet also and add to the overall length.

All put togeather in a single UDP packet, the length of can exceed your network MTU setting and get truncated. When this happens, the Kaillera client doesn’t realize it’s logged in correctly, and weird stuff happens.

I suggest you try increasing the network MTU setting on your computer. If that doesn’t work, it may be caused your router truncating your packets. If there is no way to increase the MTU in your router, try playing directly connected to the DSL or cable modem. If that works, get a new router.

There’s a very nice easy to use free program called TCP Optimizer that will tweak all your registry settings including MTU here:

You want your MTU to be at least 1500.

If this works, please post back here and LET US KNOW. I can’t really test this problem myself because it never occurs to me so knowing it works for people that have the problem will be a big help to others.

Thanks Moosehead :slight_smile:

I did that, and still have problems- it seems to be some versions of .64 and not others though- the one that does the version of SS V Sp everyone uses seems to be problematic for me at least… The other .64 I had for KOF 2k3 was fine, but I got rid of that since no one plays 2k3 and Special is a better game (though I like both)

Are you using the official kaillera client?

try different ones:

It’s just this emulator, and that server.

Everywhere else I’m fine.

It’s starting to happen to me since 2 or 3 days ago. I tried the optimizer, didn’t work.

That server has so many issues :confused: You are likely to get a better response regarding issues of GW servers if you go and complain to GW people. Since its their “kaillera” server, they must have places where you can complain about it. Even if they thaught they are “kaillera,” I don’t see any reasons why a place like SRK forums should have these pitiful server specific threads. Bloody hell, its just another server. If it does not work for you, move on.

You can’t just ‘move on’ though.
This isn’t like Europe were servers go up and down all the time so there’s no real main (besides Rep’s which came up recently).
Pretty much everyone plays on GodWeapon and the majority of them don’t frequent SRK, nor do they want to move.
If you can’t get into GW, then your competitive pool shrinks considerably.

when I refresh, I can see all, hmm…
I agree that server is all ways packed and
has some issues.
woof that wa harsh dude! :annoy:

Is it normal that I downloaded the Kaillera 0.9 SDK client, it works the first time I try to use it, but american servers give me 100-so more ping than usual, I try the Anti3D client, still gives me 150+ ping, and then the Kaillera 0.9 SDK one doesn’t ping any servers at all?


harsh? what part of it was harsh?

i just pointed out that i wasn’t able to see the topic because i was banned from there [a forum i’ve never even been to] and i was asking if anyone could copy and paste the information.