Help!?!?! mvc2 360 fightstick pc problems

I have a madcatz mvc2 te fightstick for xbox 360
I recently had to get a new motherboard and processor for my computer and had to reinstall windows etc. Whenever I plug in the stick the computer recognizes it as a madcatz te stick. It shows up under unknown/other devices and has an exclamation point by it.

I try to manually find the drivers it doesn’t work
I have installed the drivers from microsofts website multiple times and uninstalled the stick multiple times and restarted my system multiple times.
Whenever I plug ina regular xbox controller it will find the drivers online by itself and install them perfectly.
I have even tried different usb slots and to no avail nothing has worked.

Idk what else to do this never used to happen before the stick used to work fine before. Any
help and tips would be appreciated, thank you for your time.

I suggest you read this thread. Yeah, I know, it’s long, but it seems that solutions are different depending on your PC and OS. On my Win 8 machines, the stick just worked. On my remaining Win 7 machine, I had to do the manual Windows install, select “XBox 360 Controller for Windows”, then when the wizard completed, I still had to disconnect and reconnect the stick, but it still worked. This was with my MCZ SCV stick, which is as of yet un modded. With my dual-modded TTT2 stick, it will work fine as either the Cerberus, or as the XBox controller when I force 360 mode while plugging in.

what do you mean you had to do the manual install? how do you manually install? my computer won’t recognize the te stick as a xbox controller. it just shows up as madcatz te even though I already have the microsoft 360 accessory suite installed.

When you right-click on the device and choose the option to “Update Driver…”, the wizard will give you the option to automatically search for the driver, or specify a driver manually on the first step. For whatever reason, the automatic option did not work for me on Win 7. I had to choose the manual option, and in the subsequent step, I was able to choose the XBox 360 Controller for Windows driver.

After unplugging and reconnecting the controller, plug and play detected it properly.

ya I’ve tried that and it won’t let me do that either. that’s why this is bugging me so much, I haven’t seen anyone else with the same problem as me and so I have no idea what I’m supposed to do I feel like I’ve literally tried everything

Double check your BIOS settings

what should I change in my bios?

Depends on your Bios to be honest, check the manufacturer’s manual for it

what should i b looking for in the bios, anything specific?

USB settings. I/O settings it varies.

I can look what my own BIOS is set up but thats my bios your would be different
Just look up your mother board, go to the manufacturer’s website and download the manual for it

tyhank you guys for the help I got my stick to work!! :smiley: