Having a strange problem with MK9

I’m having a strange problem that I’m hoping you guys can help me diagnose with my stick. Its a custom built 360 stick made from an old madcatz padhack.

After bringing home MK, I pop into training mode to see if theres anything I may have missed over the years that was new. After a few minutes I come to realize that DURING A MATCH, I can’t jump straight up, or duck straight down. db, ub, df, and uf all work as they are supposed to be. Whats stranger is that when I hit up or down, the game registers the input, (confirmed by showing the inputs onscreen) but the character still doesn’t jump or crouch. Additionally, the straight up and down work in all menu screens.

I thought maybe I had some crossing signals so I made sure no wires were touching other contact points etc… Any ideas? I’m kind of at a loss for what do do here…


I going to ask you first, are you getting this issue in any other games?
Try to test out your stick for any other stick you might have.

You can also plug your stick into your PC (assuming you used a wired controller), go to the game pad properties (its on the control panel in Win Xp or Devices and Printers in Vista/ Win 7) > Left click and click on Game Controller Settings > click to highly your controller if it is not selected already and click on the properties button.

Once there, test out all 8 directions on your stick and all the buttons. On the PC the HOME button will not show up on Xbox 360 controllers (this is normal), if you have the controller dual modded with a Cthulhu or ChImp, home will register as Button 13.

In game menus in MK isn’t a good indicator of your directional not working on your stick, since menus would Right and left if the menu only works for up and down. So going Right and up on a menu registers as up.

Once you established a pattern you can from there home-in on what the issue actually is and properly trouble shoot your stick.

I’ll plug it into the PC tonight.

Used it for SSFIV about a week ago. Didn’t notice anything, but then I usually use Hakan and don’t do too much neutral jumping. Any Downward movements would be downback, so I might not have noticed (i was also drunk…)

Some more details:

My stick is wired to the d pad a la a normal padhack. Since I never put plexi on the bottom, I tested out whether or not the nub for the analog stick worked and got the same result. As I said, with input display on, my ups and downs were registering, but I still wasn’t jumping.

I was going to make a thread about this as well. I have the same issue with my dual modded VSHG. The only time I’ve seen this was with VF5, were the character would auto attack or block. But to fix that issue, all you had to do was have the triggers set to “NONE” in the control settings. MK9 has no such option(That I’m aware of)If MK9 would allow you to set the buttons to NONE, the problem would go away. I don’t know why the option is not there.

Yeah I’ve got the same issue going on with my homemade stick. Been playing on a fightpad in the meantime. In training mode I can see that right trigger is registering an input here and there. Perhaps we just need to adjust the position of the controller board inside the case? I’m gonna try that out and see if it makes a difference.

I modded a TE stick for a friend of mine months ago it a PS3 stick and I pad hacked a madcatz 4716 to use with xbox360, he only played SF and MVC and used a 6 button layout and set the triggers within the game to “no function” so we never saw a problem until when he tried to use the stick to play MK9. When using the stick to play MK9 it would randomly hold the right trigger which default for MK9 is to block so when we unhooked the USB cable and re connected it, sometimes for a few seconds or more it would operate fine then all of a sudden right trigger would activate and act as if it was held down.

What is very weird is that when i pad hacked the madcatz PCB i never pad hacked the triggers at all, nothing is soldered off of any of the pods but still something seems to activate the right trigger. I pulled the PCB and nothing was touching the pods for the triggers and ran a voltage check and everything seemed to be normal.

Seems like a similar problem but I wonder what is causing this?

that happened to me the other night in story mode. I just figured it was because the game was loading in the next scene or something. Because it went away. And it only happens in MK.

Hmm to me it sounds like either there’s something wrong with your triggers or that maybe MK is extremely sensitive when it comes to the pull of the triggers. I’ll try out my dual modded VSHG later tonight when I get home, It’s got a padhacked madcatz pcb in there.

What’s up ShinobiFist, its been a while.

I am also having many of the symptoms described here and again, fine in SF/MvC etc. Pad is also a MadCatz wired.

I think it’s a combination of 2 things,

  1. MK is VERY sensitive to analog/trigger inputs, there seems to be practically no deadzone.

  2. MK doesn’t let you disable buttons, so problematic trigger wiring will have been hidden in SF but not in MK.

I noticed that when I left a character in training mode with inputs on, I would see the occasional trigger press, character would switch stance or throw. I don’t have the triggers wired to anything and the pots are glued in place (full of glue actually) I noticed that when I moved the right analog stick nub down or left, I would get lots of trigger activations. I’ve managed to workaround this by putting some Blutack (re-usable sticky putty stuff) over each stick and tweak each one until I wasn’t getting any more inputs showing (left it sitting in training mode for 20mins or so)

I have also seen the symptom of not being able to jump like the original poster mentioned. Obviously there’s a problem somewhere still, I’m convinced it’s the pots on the triggers, the superglue seeped down under the disc when I glued them so I suspect it’s causing them to become an open circuit, which is causing havoc. I’ve ordered some 10k resistors to remove the trigger pots, although at the moment it’s ok with the sticks held in place.

This just happened to me too. Madcatz SE stick. Only buttons were swapped out. Can’t neutral jump or duck. Works fine in MVC3. Restarted MK, still having the issue. I’m about to frisbee this glitchy ass game out the window.

Does anyone have a link showing the correct place to solder resistors to neutralise the trigger pots on a common ground MadCatz pcb? Has anyone done this yet?

same issue on 2 m$ wireless modded customs. 6 button layout, wasn’t using the triggers- just bumpers. hacked the triggers and used them instead. everything’s fine now.

quick google image search will produce what you’re looking for thecapsaicinkid: