GGPO emtpy rooms problem

I read over on the GGPO forum about some people having this problem. You log in, and when you do, you’re either the only person in the room or the room is empty and your name doesn’t even show up. Also, sometimes if someone challenges me or I challenge someone else, the client stops responding and I can’t chat, can’t make new challenges, can’t be a spectator, it just stops working.

I read that the way to solve the problem is to get a new modem (wtf) because supposedly it isn’t forwarding ports properly. I have a hard time believing this is the problem, I’ve forwarded my ports to a static IP for my PC and only my PC, and then checked it with PFPortchecker and it has verified that my ports are open properly.

My host file is properly set up.

My ports are open.

My firewall is turned off.

Yet, GGPO still messes up. I’m about to give up on GGPO.

I have never seen this problem and first time I heard of it.

Where did you read that it is a common problem?

Try it on another computer. Maybe your installation is messed up (or you can delete everything except roms directory and reinstall)

What kind of OS are you running? Also, when was the last time it actually worked?

It works randomly, sometimes it does and sometimes it doesn’t. Could be within 5 minutes of itself. Also, I’m running Win 7 64 bit.

Hey papasi, nice to see you here. You can see a few other people have the problem on the GGPO forums.

Supposedly, the uh “solution” is in this thread.

It really makes no sense at all. If your ports are open, they’re open, how could the router not be forwarding them properly if you can verify they’re open? I refuse to believe that is the problem.

How long have you had this router? Keep in mind that sometimes your router’s IP changes. Not to mention if you have a firewall installed to your router. Is there a way to test this wired? Try it for a week to diagnose the issue. If wired works perfectly (modem to your PC; not modem to router to PC in wired).

My modem is a router/modem combo, the firewall is turned off and the ports are open properly, I can verify that the ports are sending and receiving data with the firewall turned on or off. I’ve tested GGPO with the firewall turned on or off, the same thing happens. I also have my Windows firewall turned off and it still has issues. I have tried WAN Blocking both on and off and the same problem persists. All through out any of this, the ports still verify as open no matter what the settings are. Of course, to be sure, if I close the ports, then they report as closed, so the port forwarding is working properly.

My PC has a static IP, the modem may or may not get new IP data from time to time.

I’ve had the modem about a month and a half, I bought it myself so I can’t just call up the cable company and request a new one, and I doubt they’d send me one as good as the one I already have.

That explains everything. Modem/Router tends to be an issue. You don’t know how annoying it is when I have to port forward the router for my friend. Especially when it’s a Verizon’s modem. Also, they should be able to send you one free of charge. You’re paying to rent it anyways.

I’m not paying to rent it, I purchased one myself. How could it really be an issue? I never have this problem with other games.

If you’re referring to console/PC games (starcraft, counter strike, diablo, major games for PC). That’s a different story. GGPO uses a P2P connection.

Is it really a modem issue though? The client itself stops responding, entirely, if someone even challenges me at times. It’s rare for me to even be able to play people, but why should the client itself stop working?

Care to tell me who’s your provider? Also, there are product(s) that won’t last a month. My friend just spend 700 dollars on a brand new computer. The power supply is officially dead. Didn’t last more than 4 months. There will be times where we get a defected item.

You have two options.

1: Continue to use the product
2: See if you can get a replacement.

Comcast is my providor. Yeah, I know some products suck, but the gateway seems to work fine. I don’t have any problems with it other than GGPO not working. Oh well.

I’ve had power supplies go on me before too, then I started buying more expensive modular ones and it’s lasted much longer. Same with anything, skimping on parts usually causes nothing but headaches, so I’ve learned to just bite the bullet and pay the few extra bucks to get something nicer. Which, I thought I was doing when I bought my cable gateway, lol.

If you have a laptop, try it on a laptop (with port forward changed to laptop).

If it’s the same problem = issue with your network. (Bring your laptop to a friend’s place and verify it)

Good idea, I’ll try that when I get my hands on a laptop. One of my friends has one so next time they’re over, I’ll test it.

Ok guys, so by elimination I found out exactly what the issue is. On certain gateways you can put your gateway into modem or router mode. When in modem mode, it uses NAT only and the ISP assigns your modem an IP which is public to everyone. Your machine doesn’t get an IP, only the one the modem has. In this mode, there is no routing or port translation. GGPO and supercade both work fine in this mode.

The problem comes when you put your machine into routing mode using NATP, which is NAT with port translation. Basically, the ISP assigns your modem/router an IP, then your modem/router assigns your PC and other devices on your network an IP. These are internal IP’s that the modem should forward ports to. Trouble is, it seems to work and seems to not work. I’m not sure what is breaking the port translation on this device in particular.

As I stated before, I used a port checker tool from to check my ports. If I turn on WAN blocking, my modem can’t be pinged since it’s hidden from the Wide Area Network, but my ports can be tapped as open or closed. The program reports they’re open, and of course, the ports that are closed are reported as closed, too. The program eMule has a port testing option too, open those ports and it tests positive. The thing about eMule is that it uses a browser to test your ports. Oh, and of course, both GGPO and supercade work with no problems at all in this mode. The problem is, ALL of your ports are open to everyone with a public IP that everyone can see. You basically have no security in this mode.

Then, there are other sites, like Shield’s Up which can only test TCP and of course, it tests negative and reports the ports as closed. It can’t even test UDP so there is no point in checking those ports. I used another client program called nmap, with the Zenmap GUI front end, to test my ports. They all test closed or unknown. On client programs, GGPO will work and won’t work, most often not working. Supercade doesn’t even get past the log in screen and will give you a time out error. Basically, you get security with this mode, but for some reason these programs aren’t working.

So, we have a strange situation here. I’ve emailed Motorola to see what they’ll say. I’m sure I’ll get some BS and they’ll probably blame it on the cable company, and of course, I’ll email them next.

Maybe I’ll get to figure this out. Who knows.

…English Please?

Here I’ll do it:

Just keep playing with the config and you will get it eventually.

I’m currently having this problem and i think its because i have a Modem/Router now…but i did have one before and GGPO worked fine.

I’ve moved aand set up GGPO on friends computer’s, so this is like my 5th time setting up GGPO, and i swear it gets harder to do it every time!

Is ggpo down for anyone else?