First time Modder: PS3 no longer recognizing the stick

Hey SRK, my first post in the tech talk thread. I looked at a bunch of youtube videos, specifically this one because I wanted to learn how tighten the spring on my stick and also replace my buttons. Anyways here’s the rundown of events that lead to this problem.

I own a Tekken 6 HRAP3 for the PS3 and had it for nearly 2 years. All Hori Parts. I got a hold of Sanwa buttons and also tighten the spring simultaneously. First thing’s first, I opened the stick with no problems, switched the buttons, and then I started to begin the JLF part, and that’s where the problems started happening. First thing, was that when I pryed the stick open by forcing the E-clip off, the E-clip flew off somewhere in the living room where I was working on the stick and I lost it. I directly ordered a new one online with pretty much all of the components of the joystick resting outside. I left them all on the floor for 3 days until the package arrived today and I continued to repair the stick. I reassembled the stick just “how I remember” by working backwards and stuff. And then when I try to connect it to PS3 it doesn’t register.

When i first plugged it into the PS3, I saw a message saying something along the lines of “The PS3 has reached the power limit on the USB, Please remove one of the ports” or something along the line of those. Moving the joystick around and pressing buttons didn’t do anything. I thought maybe the cable band entering the Joystiq was put in backwards so I flipped those and after that I didn’t even get a single notification on the PS3 making me think I screwed it up even further.

But then I tried plugging the stick into the PC and testing it on an SNK emulator paying Last Blade 2. When I did that, all the face buttons including the [],/,O,X,Home,R3,Start,Select, etc. all worked and registered in that game. But the stick just wouldn’t register regardless of whatever directional input I put in. I then tried flipping the Main Base with the microswitches in different directions thinking that will change something but nothing happened. I have no idea what to do or what I did wrong. Here is a picture right now:

The stick worked fine before, but now everything just turned to shit and I hope it’s a simple problem I overlooked and can be solved. I really REALLY can’t afford getting a new stick right now. Will appreciate any help anyone can offer. Thanks in advance.

it could just be a simple mistake. notice the pink circle.

it looks like your joystick has been switched to R instead of either D or L. that’s the control for your jlf, indicating d-pad, left thumb stick, or right thumb stick. try that first.

as for the ps3, i believe the reason that message comes up is because you have too many usb devices plugged in? i hear if you leave your dual shock controller and other devices devices unplugged for a while it’ll be alright. try to google that error message just in case, other people might know the answer to that one.

Thank you for the reply, I took that picture right after I checked different analogue stick routers. At first it was on the D-Pad, it didn’t work, and it didn’t work either when I switched to the left and right analogue sticks unfortunately. But again this was all tried on the emulator.

And when I had this problem on the PS3, I only had one other USB B cable cable that wasn’t charging any Dual Shock controller so it shouldn’t have had an effect. I removed the cable regardless and after that I didn’t even get the error message. Just no response at all on the PS3.

I’m just wondering if anyone else had an issue like this… I’d assume it’s a common mistake since this is the first time I’m doing such a thing and I’m getting an error.

I replaced the pcb on my friends HORI because he was experiencing the same problem. We both tried all kinds of things like disconnecting the USB, soldering the USB cable directly to the PCB. Disconnecting/reconnecting buttons and wire harnesses. In the end i replaced the PCB with 10 dollar controller PCB from deal extreme. It was a give and take. The stick lost the function of turbo but gained PC compatibility because the PCB was a PC/PS3 controller

Here is what it looked like

Sent from Epic 4G Touch using Tapthatas… uh…Tapatalk

My friend found the reason this was happening. It was because of the USB wire. Whenever I travel with the stick, I have to wrap it around the entire box since there isn’t a separate compartment to keep the wire in. This screws up the wire and hence why the signal was only partially going to the PS3. Apparently it’s a very common problem with those pre MCZ TE era Hori sticks.

Thanks for the responses regardless guys :slight_smile: