"disc is unreadable" message after installing game on xbox 360 hard drive

Okay guys I have a problem. I bought an xbox used in a repair shop and it came with a 90 day warranty. I bought a used copy of ssf4 and started to play it. Everything looked fine until I came into the vs screen when the system loads the match before it begins, and the message saying “disc is unreadable” popped up. I thought that maybe the disc was at fault so I returned to the gamestop I went to buy it and exchanged it for another one ( no scratches on disc btw ). Tried to use that second disc and the same error message popped up. I then thought that the guy at the repair shop sold me a bad system so I called him and I went to day to fix the problem. He tested it, and he told me that the problem was on my profile. That maybe it was corrupted. I told him that having an online profile or avatar has nothing to do with a problem in the system itself. So I told him to erase that profile and use a brand new in THE SAME HARD DRIVE. He then realized that there was a problem with the HD so he then replaced it and gave me another one. We tried playing the game with that new HD and everything worked smooth. Now I brought the system to my place, I recovered my gamertag, profile, etc … and tested the game. It worked ok.
NOOOOOWWW … I INSTALLED THE GAME as I installed it before. Then I tried playing the game and the “disc is unreadable” message appeared. I deleted the game from the Hard drive and everything worked again as if nothing happened.
Now what? Is the problem coming from the HD? Is the problem coming from an UPDATE to the system or to thee SSF4 game?
I really want to install the game, and thats why I bought a bigger HD. Anyone have had any experience of the sort?

P.S. I checked some info on the web and some say that the HD may not be the original from microsoft and that may be the cause of the problem. Im new to the xbox scene ( I only play on ps3 and bought an xbox recently coz psn was down ), so I have no clue whats going on here.

They really need to be official Xbox 360 HDDs from what i understand, maybe the Game check periodically and see’s the wrong serial? No clicking noises from the HDD?

I think I have an original one. It has the microsoft logos everywhere, bar code, serial number and everything.
It looks exactly like this one: Connection Problem
Only difference being it was made in thailand and not korea.

Maybe a format is the go? seems like a weird thing to happen, does it happen in other games? Try and download a demo off live store.

Ok I will download the demo and see whats going on. Thanks 4 the help btw.

Inside my Xbox 360 HDD case, the actual drive isn’t a official Xbox 360 HDD, but a store bought 2.5 in Sata drive like the ones used in laptops, and I have no issues running games off of disks.

try clearing the system cache. go to Memory under the System Settings and you’ll find the option to clear the system cache there.

i’ve had a problem with a game not loading a stage properly and freezing. delete the installed game on the hdd if you did copy it. then clear cache. then see if it works.

I should of realized that.

Ok, so I downloaded 2 demos: black ops and dragon ball raging blast 2. Played for a while with them and didnt have any problems at all.
Also about the memory cache, I deleted it but with the game still installed. Then i tried to load it and it gave me the unreadable disc message in the press start screen.
EDIT: Right now I uninstalled the game and then cleared the cache. Now Im reinstalling it, and will post here with the results.

This is the weirdest thing that has happened to me, troubleshooting gaming wise.
I tried to play the game on training mode, and everything worked flawlessly. By the way I didnt download any updates for the ssf4 game when prompted ( just in case the updates were the culprits ). I then exit training mode, went back to the title screen and voila! … the error message appeared again. I then reloaded the game but this time I did all the updates, and I could get into training mode again. I picked my characters and everything worked fine ( I picked ryu and sakura ). Then I tried two other characters ( dudley and akuma ) and everything worked fine. NOW THEN I picked ken and “FEILONG” … and the message appeared in the vs loading screen as usual. All this time i have been testing the game on training mode with feilong as main character and the error has happened, but then when I picked other characters, the error ceased to appear. Come on, is there a problem with certain characters that may induce these errors/freezes in the xbox when playing the game from the hard drive? Again, when I play from the disc I have no problems whatsoever.
Right now Im really like … WTH?! o.O

EDIT: Also everytime I try to go back to the title menu, the message appears again ( I thought that that was caused because of the updates, but nope ). Now I only can play through disc.

I’m having this issue now that AE has dropped…I haddent installed my game to my HDD cause there was no need.my disc was fine, the game ran no problem. but a day after AE dropped…i noticed that after online matches during the ‘win pose’ my game would freeze for crazy long times (10-15 seconds) but the game would eventually run ok… but all of a sudden on Wednesday, I boot up the game and on the “press start” screen, after you do press start, and pick which device you load your profile from…the game would freeze, and then give me the “disc is unreadable” message and go back to the dashboard…i tried to play my game for 2 days…everytime, it would do that…I tried to install my game and it wouldnt let me saying the disc was unreadable…

so I was convinced my disc was scratched…so I went and bought a brand new copy today…and it still gives me that message (WTF!!! o_O ) so i went and tried to install off my new disc I jsut bought, and it installed OK, but the game still gives me the disc unreadable message when I boot it up to the press start screen…

I thought about it, and the only variable between SSFIV working, and SSFIV not working, was the AE download…so i deleted it, (along with the new install i just did of Super) and tried to run it again…if I select a device…it gives me the disc unreadable message…

but i I didnt “select a device” one time and started the game without saving and it went in…i accessed marketplace from the in game menu, and reinstalled AE…and then I could play the game, I went and played a match with no issue…

but when i go to the dashboard, and try to restart the game again, if I try to pick a storage device, it gives me the error message all over again…

i thought that maybe it’s a profile issue…so I deleted my profile…and tried to recover it, now it wont let me recover my GT saying “sign up is not available at this time”…but I went and recovered my brother’s GT just to see if it would let me and it did…!!!

plz help?

At this point you need to contact Xbox Tech Support. Corrupted profiles on the XBL network is out of range for what we do here on tech talk.

yea…now that i look back over my post, i guess thats what it has ended up being…

goes to get cell phone…

Tell us your findings…i’m sure lots of people are having issues like these.

well, I’m sure it was my hotmail account had been hacked, which in turn affected my gamertag…

my gamertag is now deleted and it still wont let me recover it…

i went to xbox.com and tried to log into my account, and it was a no go…it said my account had been compromised, and they blocked it…

I click the password reset feature, but M$ makes you go thru a shit load of red tape, cant just call customer service and talk to a person, its all automated and thru email…so now we wait…

meanwhile, my brother said I can troll under his GT…