Cerberus not working after installation?

So, I just got a cerberus for dual modding a 360 MLG TE and tried installing it today. After getting the usb wires and pcb in place, I connected to a pc and did the testing as recommended. At first, the cerberus showed up fine and work (with reverse LP/MP/HP and LK/MK/HK) in skullgirls (steam). However, I couldn’t get the 360 mode to work. So, then I plugged it into a ps3 and tried skullgirls (ps3) again, this time LP/MP/HP and LK/MK/HK worked fine, no wires touched from before. However, at this point I noticed start/select did not work. Last, I tried plugging the stick into a 360 for testing skullgirls (360) yet again (my friend really loves SG) and the stick did not show up at all.

I should note that at this point all four player indicator lights were simultaneously lit solid, no flashing. I was under the impression that at least ps3 mode would show my player indicator correctly, so this seemed odd to me.

After this, I took the PCB out, tried re-seating all of the wires again, then plopped the pcb back in. This time, nothing showed up on any system.

Later, I tried taking some wires I had that had cables with soldered tips, I figured the connection would be better and I could just twist the leads to see if the pcb was working. So, I inserted the wires w/ soldered tips into the terminals and twisted the other ends with the usb wire. Again, no good. I’m getting a bit frustrated so I’m calling it good for today.

I’ll post some pictures up, but I don’t know why this isn’t working. I don’t know for sure, but suppose if I shorted one of the pcbs with one of those copper strands, would either/both pcb be shorted and dead? Or would there be no damage after a short? Double-checked the pins, all of them are straight and I’m confident that I pressed the cerberus down on the 360 pcb pretty firmly. Also, I have a multimeter, any things I should test?


The usb wires in the first picture are for the X360-IN terminals and the third picture are for the USB OUT terminals.

Seriously, your wiring needs some work.

You can’t just twist splice wires with no way to secure or insulate them.

And trim back that white fiber thread.

I’m twisting them atm to make sure that everything is working. Once I confirm that everything is good, I’ll probably try to solder the wires together and slap some electrical tap over them.

I’m new to this, haven’t done something like this in a while.

Have you removed the cerberus, and reconnected the xb360 board to test? Rule out the possibilities of a short there. If you have a short on either board, there may not be any physical damage…and you could smell ozone.

Don’t use electrical tape. The adhesive on it is far from permanent and will peel off on its own in time.
Always use heat-shrink.

I had not considered this. Will do when I get back home.

Need to pick some up, but will do after I confirm everything working.

Wait, why are you using ethernet cable wire and splicing? Why aren’t you able to just follow the normal install method? Was this a stock stick to begin with?

Just an FYI, but ethernet cable doesn’t always play well with those connectors, which can compound your problem. It also looks like your stripping the wires as well?

It was some wire I had laying around, so I decided to use it. And yes, it was a stock stick.

What I had done at first was just strip the usb wires and insert them into the terminals like the installation had said to. When that didn’t work (after testing on consoles), I figured that perhaps I wasn’t getting a good connection (couldn’t tell if the wires were showing in the back of the terminal). So, I dug around for some wires that looked like they could have a good connection.

So, you’re saying to ditch the ethernet wires? I can try that too, though I wish I had a decent soldering gun to at least solder the USB wire tips. Frayed copper just doesn’t want to go in without a fuss.

Oh, and thanks again for the quick shipping! I was going to send a follow-up email after I had gotten everything to work, but well… this happened.

Someone correct me if I’m wrong, but I believe you’re not supposed to strip the individual wires in the USB cable. Just the thicker black sheath, but not the individual White/Green/Red/Black wires inside. The connectors on the Cerberus punch right through the individual insulation.

Also, soldered tips on wires doesn’t necessarily make it better, and I think in this case makes it worse: soldered parts on wire are very hard and brittle. If the connectors on the Cerberus are supposed to punch through the smaller wires for a connection, those connectors definitely will not be able to punch through the soldered wire; those aren’t screw terminals.

Oh my god. I read through the installation guide again, and the directions only say to strip the outer black sheath. Nothing about stripping the individual wires.

Fuck me, I got too excited and didn’t read properly. I hope I didn’t mess the terminals up. Today’s going to be a long day until I get home.

Yeah I’d ditch all the ethernet wires/splicing and go back to the standard install instructions, use the cable itself, don’t strip the wires. I would cut a bit of cable off the end of what you were working with so that it’s nice and clean, remove the outer sheath leaving the main wires insulated, and go from there.

There no reason to twist wires if you are using the existing stick wiring and terminals. You did the text book example of what not to do.

Get rid of the Ethernet wire and connect the USB cable directly to the PCB.
By using that thinner wire from the Ethernet cable you are changing the electrical impedance of the circuit. Change the impedance too much and the board will not work.

Also the method you choose to spice your wire is prone to becoming lose and cause faults, breaks and even shorts.

I don’t know what to do now. Cut the ends off of the USB wires made sure I could see them through the terminal windows, made sure everything was tightly connected. Either something is loose somewhere, or either one of the boards is fried. Plugged into PC after each attempt and nothing.

Earlier, krieg mentioned testing the 360 board but I have no way of doing so unless I strip the wires again and I’m hesitant to do so. Any other tests I can run, preferably with a multimeter?