Button issue with HRAP V3 SA on MvC3

This is hardware related, so bear with me…

First of all, I did try playing Marvel Vs Capcom 3 after I picked my copy on Saturday… Long week, no opportunity to get it until today.

I tried playing with the HRAP V3 SA I bought last Christmas but noticed something funny right away. In DEFAULT button part, the L1 button is used switch to Assist Player Character 1 if held long. R1 is for Assist Character 2.

Anyhow, after futzing around for some minutes, I’m noticing the L1 button is NOT switching characters no matter how long I hold it. It’ll call up a character switch but WILL NOT allow me to do a permanent switch. No issues with R1.

Since I wanted to play the game with full switching, I remapped R1 to Assist 1 and R2 to Assist 2… Issue solved — for the moment.

Wanting to make sure this was not a software issue, I turned off my PS3 and installed an HRAP stick. In Default button mode, my L1 button on that stick (Astrocade layout) is working like it should. I can switch my Start Character for Assist character 1.

Power down the system again… and try swapping the my existing L1 button in my HRAP V3 SA for a fresh button. L1 still doesn’t work as it should in the game.

Never had an issue with the V3 SA acting screwy on any of my other PS3 games including downloaded games like SSF2THD and MvC2…

I wonder if the V3 SA has its own BIOS and has a glitch in it, or if something is peculiar about my stick… Why is this game an issue for it? I don’t think it’s button related because I’ve swapped buttons out and it’s recurring with another Sanwa.

I’d like to see if someone else is having the same issue with their V3 SA with this particular game. Seems very weird that it affects this Hori V3 stick and not the earlier HRAP 3 SE I tested the game with.

I am having problems understanding what you’re trying to say(or atleast the terms you’re using). So you are not playing with the true/recommended button layout? Unfortunately for MvC3, the true/recommended button layout B/Beta(or whatever it is) so it looks like this:
L - M - H - None
S - P1 - P2 - None

The stupidest thing with fightsticks now that I find really unnecessary are that there are 3 types of pre-configured button layouts. In SSFIV, they were:
Type A: Standard settings
Type B: MvC2 button layout
Type C: Microsoft button layout(They require licensed products to rearrange their A, B, X and Y differently)

I am assuming that this is either a button configuration problem or maybe you like to play with the straight 6 buttons(Square and Cross button unassigned) and maybe your turbo is set on for your L1 and L2 buttons.

I’ve used both my Qanba Q3 and Hori HRAPP EX VLX on both versions of MvC3 and no problems. Just to be safe, I change my buttons individually and I’ve had no problems so far.

Added: I just realized that it’s GeorgeC that created this topic. Ignore most of my post because I’m sure you know what you’re doing. Probably is a hardware-related problem.

Yeah, it’s hardware-related.

I wonder if Hori changed something about the PCB in the V3/VX series joysticks. Does these actually have FLASH-ROM? A BIOS or some control program in their chips? The HRAP 3 line sure doesn’t seem affected at all…

I’m seem to recall reading that Sony in the past did a system update that enabled the HRAP 3’s to play PS2 games in the backwards compatible PS3’s.

I don’t think there’s anything wrong with the wiring in my V3 SA since the same button worked fine in other games.

It just seems to have an issue with the one game and honestly it’s not that big a deal since you can remap the button assignments.
Gotta say though that I usually stick to default layout within games since A) there are no nearby arcades that have this game; and B) I’m not wild about changing button layouts as it is to be quote “more comfortable,” and C) I’m used to different games having different button configs so it’s not that big a deal… Just a bit concerned that if this is a V3/VX issue that it may pop again – very inconveniently.

I’m still getting used to how different MvC3 is from MvC2!

I don’t normally use L1/L2 myself, but I tried the default button layout to see if the same thing happened to me. L1 switches character perfectly fine. Tried it on the other 2 V3-SA’s I have, L1 works on those too.


Looks like it may be your particular stick. If I’m not mistaken, you bought yours from Newegg around the time they went on sale for $99. Both of our V3-SA’s are more than likely from the same batch.

Tested this on my V3 SA as well, no problems. Everything works fine.

Huh. Weird…

It’s not a deal breaker from me, honestly. I guess I’ll experiment today and try something else. Maybe swapping the existing L1/L2 buttons in my V3-SA or putting in a PS14D microswitch in the L1 button to see if that makes a difference.

This is the first time I’ve encountered a problem with any of my joysticks…

I think you’re right, scabby. We probably do have sticks from the same batch. I did buy my V3-SA during the Newegg sale in mid-December. I wouldn’t consider a button malfunction/L1 to be a reason to return if it seems to be fine with every other game I have. I’m just going have to see if it’s a stick-specific issue, a Sanwa thing, or happens with all the joysticks that have Sanwa buttons. I’ve only tested the game against a Seimitsu button sticks and the V3-SA Sanwa button stick.

I’m still not thinking the issue is me but I haven’t been playing MvC3 constantly like other people have and my issue with most games isn’t with buttons. It’s timing between joystick and button pushes and I usually get over than learning curve pretty quick…

Found what the button issue was…

It’s those darn TURBO levers!

I still can’t figure out HOW the Turbo on L1 got shifted all the way to the third spot! That’s why the button wasn’t functioning like it should have in MvC3. Sounds very silly but the weird part is that I NEVER use the turbo function on any of my joysticks!

Weird… Definitely an issue to keep aware of… I don’t know why Hori went to turbo levers on the V3/VX line, either. Frankly, I turbo’s not needed for fighting sticks. Just another thing to be aware if an arcade stick “malfunctions.”