Broken Directional Inputs on Madcatz TE mvc2 Edition

Hello, I’m sorry in advance if this ends up being a redundant question, but here goes. I recently picked up SFV on my ps4 and I started using my old Madcatz TE fightstick (the one with Marvel vs Capcom 2 art) to play it. It worked fine for a few games, then all of a sudden, I couldn’t move my character or any menu options to the right anymore. I thought that it might just be a micro switch problem, and I just happened to have an extra JLF joystick with all 4 fresh microswitches, but after I got that in there, the same right input was still not working. Does anybody know what my next troubleshooting step should be? I refuse to buy another stick if there’s any chance I can fix this myself. I’ll even learn to solder if I have to. ( I’ve been meaning to learn how to solder anyways, this’ll just be a good excuse.)

Ls/rs/dp switch

Yeah, tried messing with that a little. No dice on that front.

Does your stick work on a PS3 or PC?

It DID work on my PS3 when I still had it, and it was working on my ps4 just fine playing usfiv and I got to play for a few hours on SFV before the right input stopped working. That’s why I assume that something might be broken.

If you have it try the stick with USFIV or another game with legacy drivers (like Skull Girls or Injustice).

If it does not, start inspecting the USB cord for any damage or deformation.

Gave it a try. USFIV gives me the same issue, and I don’t see any unusual damage to the usb cord. I always made it a point to not wind the cord too tightly for just that reason…

if u have a spare USB 2.0 hub lying around, u can try plugging that in, then connect the stick and launch the legacy mode.
one of my PS3 Madcatz TEs work perfectly fine only when connected via a USB 2.0 hub to the PS4

plug it into PC and open up joy.cpl. check to see if the directional inputs are working there. its gotta either be something up with the wire-harness or pcb. I believe its the 2nd wire from the top that inputs Right. Follow that wire down to the PCB. On the PCB inspect the soldering point where it connects and then follow the trace to see if your can see anything wrong.

I rather suspect the USB cable before I suspect the PCB.
USB cable replacements are easier and cheaper than a full blown PCB issue.

I had the very same issue with the very same stick, replace the doggle/breakaway cable from another controller and see if that fixes it|cid:247411609|agid:14870303929|tid:pla-102662123089|crid:60879544009|nw:g|rnd:5340609952485674783|dvc:c|adp:1o4&gclid=COysr8D5vMsCFdgVgQod1eAEpA

It appears your link is broken

It appears your link is broken

no biggie, I was just posting the link so they could see the pic