Brand new Mad Catz TE Round 2 problem (PS3)

Ok so I got my first arcade stick ever, ordered it through It worked fine for the first couple of hours, but then suddenly it wouldn’t register :d: anymore.

Ok so I unplugged the cord and put it on the other slot in the PS3 and it worked for half an hour or so again, and then it suddenly stopped working again and since then it has been pretty much on/off, sometimes it works but then suddenly just stops working and I have to unplug the cord/restart my ps3(which doesn’t always solve the problem).

Sometimes it doesn’t work at all and sometimes it works when you push the joystick :d: as far as you can.

Just to be clear, this problem is only for :d:, every other button/direction works perfectly. This stick is also brand new, I’ve only been using it a few hours. It hasn’t fallen or taken any other hits either. I also tested my friends TE 2 stick just a moment ago, and it worked perfectly.

Any way to fix this or should I just send this stick back? I tested it on my friends ps3 too and the same problem existed.

Thank you for your time.

I’d call Madcatz, it’s still under warranty if it’s new.

Open up the top panel and check if this is fully plugged in

Before that though, you should try switching it to LS and seeing if it does the same, if it works flawlessly then it could be a problem with the pcb.

Thanks for the help! I tried switching to LS and :d: still didn’t work. I’ll try checking if that thing is fully plugged in when I find the thingy to open the case.

EDIT: Yay it worked! The wire wasn’t even lose or anything, but I still tried to put it in even tighter and now it works! Thanks a lot :slight_smile:

sometimes the harness isnt seated fully on the JLF and is glued so theres a gap that causes problems… good job correcting the issue!

Good to know. Yeah, Madcatz is a little shoddy sometimes.