ASUS VW266H can't display 1080p via HDMI?

I recently got the ASUS VW266H LCD monitor and hooked it up to my PS3 using HDMI. Whenever I try to output at 1080p the screen goes completely blank. 1080i, 720p, 480p work fine. I was wondering if anyone else has run into this? Should I just get component cables?

It may not support HDCP, which would prevent it from running in 1080p via HDMI. Seems odd that it wouldn’t though.

Try a different cable. I’ve had a bad cable before which did what you described, tried another one and it worked fine.

HDCP compatibility was mostly a problem with DVI ports I thought. Anything with HDMI ports has it.

I don’t have a PS3, but my xbox 360 outputs 1080p just fine on the VW266H. You should return it or try a different cable.

It does support HDCP through both HDMI and DVI. I’m hoping its just a bum cable because the PS3 seems to think everything is fine and reads it as a supported resolution. Also the monitor is staying on even though its blank which means its getting SOME signal (audio is working) because when it gets no signal it goes into sleep mode automatically (like 2 seconds).

What 1080p source (games, BluRay) are you using?

Interestingly enough I just received the 24inch version an hour ago. No such problem on my PS3 or 360 or DirecTV Receiver. Never heard of a cable having issues with a specific resolution but can’t be the monitor(atleast lets hope not).

Just the PS3, it goes blank during the display settings setup. It IS possible the hdmi cable can’t handle full 1080p properly due to interference or just being some lame no-name cable. I’ve got a new one from monoprice and a component on the way just to double check. also gonna check to see if vga and dvi output at full res properly.

The PS3 doesn’t output 1080 through component. Though I do think that the cable is the main culprit, it’s still interesting that it only displays one resolution.

Well 480p, 720p, and 1080i all work fine. 1080i actually looks… weird… Like its jittering especially on text.

Not that anyone was following this thread, but if anyone runs into this issue in the future: It was the HDMI cable all along. I got a better (and lower-priced) one from Monoprice and all is working properly now.