Arcade Fightstick Stopped Working

I own a Madcatz Tatsunoko Vs Capcom Arcade Fighstick for the Wii which I use to play a lot of fighters on the PS3 (with a Wii to “PC” USB Adapter which worked perfectly) and the Wii. When I was playing Street Fighter the other day it completely stopped working on me! None of the buttons work, the home button doesn’t work, the turbo doesn’t work, the joystick thing doesn’t work…nothing does. I was wondering what could be a possible cause for this and if there is a way to possibly fix it. Thanks in advance!

  1. I’m presuming that the TvC stick is still 100% stock?
  2. Have you tried to narrow down what’s not working?
    … 2a) Use the stick on an actual Wii/Wii-U
    … 2b) Use the entire setup on a PC

I will say it’s less likely that your stick died, and more likely that your adapter crapped out on you.

Right after that happened I tried it on my Wii and Wii U and it still didn’t work. That’s how I came to the conclusion that the issue was with the stick itself rather than the adapter that I use for the PS3. I have yet to try it on PC but I think it’ll end up being the same thing.

And yes, it is still on stock (Amazon). A friend of mine also owns it and uses it for the PS3 with the exact same adapter I own.

Ok, NOW we’re troubleshooting. Your original post with a summary of “It’s not working! How can I fix it?” with no additional information was rather vague.

Next questions:

  1. Could it be that, through transport/storage/etc, you bent the cable and killed that?
  2. Have you opened up the stick before? Take clear pictures of the insides; it might help.

You should probably also change the title/subject to this thread, as it’s vague as well. AT LEAST you should mention that it’s the Wii TvC Fightstick.

  1. I store it in the box it came in as soon as I’m done using it with the 2 foam things and stuff. Although I’m not sure if this could be it.

  2. Yes, I have opened it before (twice). I opened it up once to label the buttons and colors on the inside just in case I got some Sanwa buttons in the near future and an octagonal gate but I did not replace anything. The second time was when it “died” on me. Opened it up to see if there was anything wrong but I’m only a noob so I can’t exactly tell…everything looks fine to me.

I’ll post a picture or two in a little bit.

EDIT: Here they are. Pardon the quality…only had an iPod on me T-T





Since you say that there’s nothing that works on the stick anymore, and we’re pretty sure it’s the stick and not the adapter, there are 2 possibilities:

  1. Your wire is shot from being bent at bad angles
    … Verification: if you have a multimeter handy, you will want to check continuity on each of the 5 wires from where they’re soldered on at the PCB side, and at the end of the wire at the plug
    … Solution: if this is the case, you’ll need to re-solder in a new cable; you can get some Wii Nunchuck/Classic Controller extension cords online. You’d then cut off the female end of the extension, de-solder the old cable and solder the appropriate wires in the proper locations on the PCB

  2. Your PCB is fried from something
    … Verification: the Wii Remote wire appears to be intact and properly soldered on, and all other wires are still in place. Use the multimeter and probe the Vcc point on the PCB (not at the wire’s end; somewhere else) and ensure that you’re getting 5V. If you’re not, the PCB is likely crapped out
    … Solution: not much you can do other than replace the PCB. Or gut the case entirely and install an actual PS3 board like a Cthulhu/MC Cthulhu, Cerberus, or PS360+ board.

Sheesh! I’ll see if I can take a look at it (option 2 seems to be the more likely one). Thanks for the help!

From trouble shooting and fixing other peoples sticks, number 1 is most likely.